Monitor display goes black and pops up as "No signal" randomly after 2-3 hours

Nervesofsteel

Junior Member
Jul 13, 2016
15
0
6
Hello everyone,

I have this weird problem now , i have two graphic cards gtx 560ti and gtx 1060 , when im using the on board intel graphics the display doesn't go black and stays for longer hours until i turn it off , but whenever i either use my gtx 560ti or the gtx 1060 , either it might be gaming or browsing the monitor display goes black after 3-4 hours randomly , if i restart the pc immediately it goes black again in few minutes.

If i leave the pc turned off overnight, with the gpu next day it runs fine for 3-4 hours again. I don't really understand it , i thought it was a gpu problem , but i tested with both my cards and it still occur.

It doesn't happen when im using intel hd graphics , removing both the gpu's.

I tested my gtx 1060 on my friend's pc and it is working flawless , so its not really with my gpu problem.

I have a corsair cs650m power supply , which is more than enough for gtx 1060 as it requires only 500. Any suggestions?
 

[DHT]Osiris

Lifer
Dec 15, 2015
11,009
7,930
146
Monitor might be overheating, if symptoms exist with 2x cards (eliminates vid card), and re-occur post-restart within a few minutes, but fine after snoozing/turning on after several hours of being off.

Try lowering the refresh rate in windows (might help?) or like, set up a box fan pointed at it or something to test. If it lasts longer with a fan getting some air out of there, you found your culprit.

If that's it, crack it open and start getting dust out, find a way to rig a fan inside, or find a new monitor :p
 

ASK THE COMMUNITY