mkv in media center

Mattd46612

Senior member
Jan 23, 2005
670
0
0
I can't seem to get a 1080 .mkv movie to play in my windows media center. Ive downloaded and installed the codec packs and have ffdshow on there also. I see the file in media center but it just says cannot play. Ive also seen a registry fix is needed to play .mkv in media center but I dont know how to make the .reg file. These were the .reg commands:

[HKEY_CLASSES_ROOT\.mkv]
"PerceivedType"="video"
"Content Type"="video/x-matroska"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\.mkv]
"Runtime"=dword:00000007
"Permissions"=dword:0000000f
"UserApprovedOwning"="yes"

anyone have a clue whats going on here?
 

loup garou

Lifer
Feb 17, 2000
35,132
1
81
Originally posted by: Mattd46612
I can't seem to get a 1080 .mkv movie to play in my windows media center. Ive downloaded and installed the codec packs and have ffdshow on there also. I see the file in media center but it just says cannot play. Ive also seen a registry fix is needed to play .mkv in media center but I dont know how to make the .reg file. These were the .reg commands:

[HKEY_CLASSES_ROOT\.mkv]
"PerceivedType"="video"
"Content Type"="video/x-matroska"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\.mkv]
"Runtime"=dword:00000007
"Permissions"=dword:0000000f
"UserApprovedOwning"="yes"

anyone have a clue whats going on here?
I haven't specifically tried any 1080 mkv's, but the procedure I've used is the first regedit you have there, plus ffdshow and haali media splitter installed and mkvs are thumbnailed in WMC and play fine. I don't know about the second regedit. I'd nix it and uninstall any codec packs (keep ffdshow of course), then try installing haali
 
Oct 4, 2004
10,521
6
81
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.mkv]
"PerceivedType"="video"
"Content Type"="video/x-matroska"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\.mkv]
"Runtime"=dword:00000007
"Permissions"=dword:0000000f
"UserApprovedOwning"="yes"

Put that in notepad and save it with a reg extension; double-click to execute it. The first line is important.