Major stuttering when streaming over browser (Revisited)

Charlie98

Diamond Member
Nov 6, 2011
6,205
38
91
RE: HTPC...

HTPC: i3 2100, Giga B75M-D3H, MX500 120GB, 2x 5TB HDD, 4x 4GB Team RAM, EVGA GTX950 FTW, Corsair CX430v2, Define Mini, W7, WMC/MB

Although the specs in my HTPC are older, it has a modern video card, is Cat5 connected to the ATT router, and otherwise works very well.

1) I can watch movies OK from local (HDD) storage.
2) Amazon Prime and Netflix, viewed through Firefox, stream well. There is a little screen tearing now and then, but nothing awful.
3) Nothing else streams well... I get the 'every 3 second hiccup' in the video, even though the audio streams seamlessly. ATT's DVRNow was a train wreck, trying to stream directly through the (Visio) TV with the built in utilities doesn't work (connected via wifi.)

We are trying to make a change to our viewing content, but every time we try it through a browser... it's a complete fail.

I'm wondering if ATT is throttling my internet connection, or if my wiring is suspect? Just looking for ideas...
 
Last edited:

mindless1

Diamond Member
Aug 11, 2001
5,150
381
126
Do an internet speed test or 3, but odds are it is just congestion on the pipes between them and you. What ISP tier, data rate do you have? Often people get a much higher rate than their streaming needs require, just to get past this kind of temporary congestion.

If there's any setting available to buffer more, do set that to a higher amount.
 

mindless1

Diamond Member
Aug 11, 2001
5,150
381
126
12Mb is "probably" a significant part of the problem. Even if the video rate is below 12Mb, you're still getting a slice of throughput like everyone else, but getting less data with each slice than the bitrate of the video requires

If the wifi signal is weak or there's congestion, that could make it even worse.
 

Morphes

Junior Member
Jul 11, 2009
4
0
66
You mentioned on firefox, are you experiencing this on chrome as well? Try chrome and see if that resolves the issue. Disable/enable hardware acceleration on the browser. Update drivers, update java and silverlight. Make sure your refresh rate is set to 60 and not 59.5 or something weird, sometimes TV's have a weird refresh rate set. Make sure power settings are set to high performance and all the nvidia control settings are set to high performance, and that you are using the GPU instead of the igpu.
 

Charlie98

Diamond Member
Nov 6, 2011
6,205
38
91
I realize it's been a while, I've had to drop the whole HTPC issue to focus on my main desktop rebuild... which went south for a while. But, I'm back... and the issues continue, but what's worse is now when we stream through Amazon Prime via Firefox, now we are getting the herky-jerky 3-second hiccup, too. Netflix remains solid.

12Mb is "probably" a significant part of the problem.
Recently, we upgraded our service... we are getting 30mbps now, as measured on Speedtest, so that shouldn't be the problem, now. And this is when nothing else is sucking on my bandwidth, or very little, anyway.

You mentioned on firefox, are you experiencing this on chrome as well? Try chrome and see if that resolves the issue.
We tried Chrome as a suggestion from ATT when we were doing TVNow (or whatever it was) and no change.

Disable/enable hardware acceleration on the browser.
Working on that now...

Update drivers, update java and silverlight.
The GPU drivers are up to date, I'll have to check the others. TBH, I haven't seen a Silverlight update in forever...

Make sure your refresh rate is set to 60 and not 59.5 or something weird, sometimes TV's have a weird refresh rate set.
Check!

Make sure power settings are set to high performance and all the nvidia control settings are set to high performance, and that you are using the GPU instead of the igpu.
How do I know Firefox is using the GPU... not the iGPU? I did check the browser settings, I disabled the automatic acceleration... I'll find out tonight if that helps.
If anyone else has something I need to check....? This is driving me nuts.
 
Last edited:

mindless1

Diamond Member
Aug 11, 2001
5,150
381
126
CPU load (task manager), GPU load (GPU-Z "sensors" tab).

You might try temporarily setting your windows power profile to full speed, full power, max performance, or however it's worded to see if that makes a difference. I mean for video but you could try CPU too, and/or both to see which, if either has an impact.

If CPU and GPU aren't maxing out, I'd still wonder if even 30Mb isn't enough for Amazon, though presumably you should have fewer stuttering instances at 30Mb than 12Mb, unless you're now choosing higher resolution/bitrate video so it's using up the extra bandwidth.

I'd continue to seek other streaming sources too. If it's only Amazon, odds are Amazon's just not able to deliver the bandwidth due to network congestion but you might also check what video compression is used. If they're using AV1 or H265 (I don't know), those may need more decoding performance but again you should see a CPU or GPU spike during the stuttering. IIRC, both youtube and netflix are starting to use more AV1 so if that's the issue, soon enough it may not be only Amazon where you see stuttering.

If you can find the same video from some nefarious source (lol) as a file rather than streamed, you might see if your hardware can play that without stuttering. I'd probably do it the opposite direction, find what the nefarious sources have, do a playback test with that, then comparitively stream that from Amazon or anywhere else where it stutters.

In the long run I think you'll have fewer issues with more than 30Mb speed tier even if that isn't your present problem.
 
Last edited:
  • Like
Reactions: Charlie98

Charlie98

Diamond Member
Nov 6, 2011
6,205
38
91
I made changes to Firefox... disabling the software acceleration, and supposedly shifting it to the GPU... that's what I think I read, anyway... and it made no difference, or made it worse, actually.

One other thing I looked for, based on something I read on another thread... the mouse pointer is herky-jerky, too, during video streaming.

As I said, streaming from files is not a problem, either in WMC or using something like VLC.

I have the CPU use gadget on the desktop open... the i3 is busy, but less than 50% on all cores. I'll go back and look at the GPU use.
 

Charlie98

Diamond Member
Nov 6, 2011
6,205
38
91
Well... that explains it. The CPU is taking the load, not the GPU.... with Chrome the CPU is running at about 75%, and the GPU is just standing there picking it's nose. How do I shift the load to the GPU? I'm at a loss, here.
 

Steltek

Platinum Member
Mar 29, 2001
2,164
185
106
There is a setting in Chrome settings (under Advanced) to use hardware acceleration - do you have that set?

1581202182645.png

You also might want to make sure the browser cache and Windows temp files are cleared.

What bitrate are you streaming it, 1080p or 4k?
 
Last edited:

Charlie98

Diamond Member
Nov 6, 2011
6,205
38
91
It is.

1080p... no 4K in my near future.

I went into the BIOS and completely disabled the integrated graphics... same-same (which doesn't really surprise me.)
 

ASK THE COMMUNITY