Solved! m.2 drive showing in windows, but not bios.

1Step2Short

Junior Member
May 24, 2019
3
0
6
#1
So, I purchased an m.2 drive after doing extensive research into the known rabbit hole that is the m.2 drive.
Confirmed my motherboard was compatible and began my install. Changing the settings accordingly in bios to "m.2" mode. Checked the boot tab and did not locate the new SSD.
Thinking it was something weirdly to do with windows I unplugged everything and followed steps I had read in a previous forums. To no avail.
Weirdly the drive will allow me to install a copy of windows on it. But will NOT show up in bios. I've tried secure boot options.(CSM)Windows Installation finding the SSD lets me know the board acknowledges it. Just won't act like its a bootable device.


Asus ROG z97 maxiumus vii hero
Intel i7 4790k
EVGA GTX 1070
Samsung 840 EVO(My current drive)
WD black game drive.
 

deustroop

Golden Member
Dec 12, 2010
1,505
47
116
#2
Have you updated to the latest bios ?

Does the bios recognize the drive when you insert it into the M.2 port and turn on the machine ?

If yes, then I suggest the following steps to install windows. If no, then I would return the drive under warranty to cover off the possibility of a defective drive.

Create an up-to-date USB install media by following the steps outlined here:

https://www.microsoft.com/en-ca/software-download/windows10

Then disconnect or disable all hdd /ssd drives but the one where you will install windows.

Insert the USB media tool, with the windows install files, into the board. Next startup and go to the board setup and ensure the board is configured to use UEFI boot settings and SATA mode is set to AHCI.

On the motherboard boot device menu, select the command that identifies both the firmware mode and the device. For example, select UEFI: USB Drive or Windows Boot Manager: USB and list that device in the first boot slot on the board.
Reboot. Install begins.

When choosing an installation type, select Custom. On new disks, the drive will show a single area of unallocated space. If there are partitions, select each one and then "delete".

Select the unallocated space and click Next. Windows detects that the PC was booted into UEFI mode, partitions the drive using the GPT and begins the installation.

NOTE: Any data on the drive will be lost
 

Shmee

Memory and Storage, Graphics Cards
Super Moderator
Sep 13, 2008
3,868
65
126
#3
What windows are you using currently and what m.2 drive did you get? If windows 10, follow above instructions. Your boot device will then be listed in BIOS as Windows boot manager. Must be UEFI on GPT drive.

For Windows 7 it would be a bit trickier, but should be doable depending on the drive selected.
 

1Step2Short

Junior Member
May 24, 2019
3
0
6
#4
Hi there, thanks for the replies. I've been working a-lot this week and haven't had much time to fiddle with it.
I've done those required steps up above a few times. However the one I missed was changing the sata mode to AHCI. I am using windows 10, and I have a 970 EVO. After posting this I booted into windows with m.2 enabled on my rig and can access the drive, and see a copy of windows on the m.2 drive. Also Samsung Magician let me run a speed test on it.
My Bios hates me.. I'll try the setting to AHCI mode first, and in the end it's looking like a BIOS update. I saw one update with change logs showing "NVME support"

I just hate updating BIOS because it's just one of those things you don't mess with.
 

UsandThem

Super Moderator
Super Moderator
May 4, 2000
11,095
689
136
#5
I just hate updating BIOS because it's just one of those things you don't mess with.
Unless it's one of those things that fixes bugs / improves performance. The Z97 boards with a M.2 slot (like an Asus Z97 board) that I dealt with all had BIOS updates to fix problems for just dealing with M.2 drives.
 

1Step2Short

Junior Member
May 24, 2019
3
0
6
#6
Yup, just did the newest bios update. I'm typing this reply from my m.2 drive currently. :) All is good. Really needed to replace my old 840 EVO.
 

Similar threads



ASK THE COMMUNITY

TRENDING THREADS