Long post. Z170 and Memory don't work. Don't know what else to do... Please help.


Junior Member
Nov 9, 2014
Hello, how are you?
I need your help. I am facing some issues with my new build and I don't know what else to do to fix it...

Let me tell the whole story, but first the parts:
- Intel 6600K
- Asus Z170i Pro Gamer
- Corsair Vengeance® LPX 16GB (2x8GB) DDR4 DRAM 3000MHz C15 Memory Kit - Black (CMK16GX4M2B3000C15)
- XFX 850W Black PSU
- Noctua NH-D14
- Samsung 840 Evo 120
- Toshiba 2tb 7200 rpm HDD
- Sapphire R9 390X Tri-X OC

I built the system and upon first boot everything was ok.
I entered the Bios and did the essential setup with no OC or tweaks and then did a clean install of Windows 10 X64.

Once the OS was installed with all the updated drivers, I ran a couple of benchmarks to test overall stability, and everything was fine.
I then proceeded to OC.
First the CPU.
I tweaked the voltages and setting and ended up with stable 4.7 at 1.35 vcore and 4.0 cache.
FCLK at 1000.
Vcore: 1.35v
VCCIO: 1.2v
System Agent (SA): 1.25v

This was stable and no issues.
Once the CPU was OK, I proceeded to OC the memory.
First thing I tried was to enable XMP.
Imediatly after this, the computer would not restart.
It would not even post...
The screen was black, and no power to either keyboard or mouse, so no access to bios.

I tried power off and power on and no post.
It didn't even returned to default saying that OC setting failed.

Tried a clear Cmos and still no post.
Tried to remove the Cmos battery, still no post.

Only way I could bring back the computer was by switching the dimms on they're slots.
That brought the computer back with a clear BIOS.
So I setup again.
On the memory, I did not enable XMP, but tried to manually set the default timmings, 1.35v Vdimm and 3000 speed.
Apply and once again, no post.

Removed one of the dimms, computer posted to bios.
Did a bios update to bios 0604.
Configured the Stock timmings, 1.35 Vdimm and 2666 DDR4 speed.
Computer booted and seemed fine.

Started playing some games.
Seemed to work fine.
But I started having some BSOD. Randomly.
Sometimes after quitting a game and returning to windows, sometimes at boot.

At the time I thought it might be due to having installed the new Crimson drivers.
Rolled back to catalyst with DDU and BSOD continued.
Then they got worst to the point where they occured at each startup. Computer would no even boot to windows.

So I ran Memtest.
The test came back with errors. Lots of them.
So I ran the test again with only one of the Dimms installed.
Test cleared.

So I thought I had a defective memory kit.
Used the computer with only the one DIMM i thought was good for a few days while waiting for a replacement. No issues.
RMA and got a new one.

When the new memory arrived, I removed the good DIMM and installed the new pair.
Settings were still the same (2666 1.35v).

Computer booted fine.
Ran Memtest and it cleared.
So I thought it was ok.

Went to bios, tried to keep the 2666 but tight the timmings.
Kept 2666 1.35v but went from 15-17-17-35 to 13-15-15-28 to try it out.

Applied and no post.
Couldn't bring the computer back again.
Tried everything.
Clear CMOS, Remove battery, replace the dimms, the computer would not post.

After many tries it posted with just a DIMM installed and on the closest slot to the socket.
The bios was reset so configured it again but left the memory stock.
Installed the second DIMM again and no post.

Tried with just a Single DIMM but on the slot far from the socket. No post.
So at this point I am thinking I have a bad board...
A fried slot or something...

Installed just one DIMM on the working slot. It booted.
COnfigured that dimm to 15-17-17-35 and 3000 speed and it booted.
Passed Memtest. Played games, no issues.

So at this point I am certain I have a damaged board.
Decided to give it a rest and go to bed.

This morning saw a new bios 0701 available.

Installed the BIOS and all the settings where reseted.
So I installed the second DIMM again and the computer booted.

Reconfigured the BIOS and CPU OC and voltages with the two DIMMS installed.
Memory speed, voltage and timming on Auto (2133, 1.2v, 15-15-15-36) and it booted.
Ran Memtest and it passed.
Passed with both dimms.

Entered the bios and tried 2666.
Had to remove one dimm for computer to post.
Once it posted with just one dimm, went to bios, set the memory to auto again, rebooted.
Installed the second DIMM and it booted again and no issues...

So currently computer is fine with all the 16gb at 2133 speed.

I don't know what to do anymore.
At first I thought it was a defective DIMM,
Then I thought it was a fried slot...

But since everything works at 2133, I don't know what to do anymore.

Has anyone had a similar issue?
Any thoughts? Suggestions?

Thank you.
Best regards.


Diamond Member
Oct 9, 1999
That memory requires 1.35 volts when running at "default speed" of 3000 MHz.
Either: replace with a set of 1.2 volt memory that can run at a default speed of 2800 MHz, or else: hope for a bios update from Asus to get your 1.35 volt memory working at 3000 MHz.
I've not seen any 1.2 volt (nominal rating) memory that runs faster than 2800 MHz.
Last edited: