Linux Mint and BOINC

Pokey

Platinum Member
Oct 20, 1999
2,589
0
106
#1
I have Linux mint 18.3. I got the Boinc-client and Boinc-manager and installed using the software manager. I used terminal to start the client, but I can't get boinc-manager to run, so I am unable to attach to a project.
I have also installed via software manager: the Metapackage, Boinc-Client-nvidia-cuda, and Boinc-client-opencl. five packages in all.
I have re-started client after installing. Still can't get Boinc-Manager to start.

Anyone want to post an installation guide for Boinc on Linux????????
 

StefanR5R

Platinum Member
Dec 10, 2016
2,291
401
106
#2
I may be wrong*, but I think you need to enable one of the following things:
  • The user who runs boincmgr needs read access to /var/lib/boinc-client/gui_rpc_auth.cfg.
    (Haven't tested this myself.)
    (This is the default on Windows, hence Windows users don't experience this trouble.)
  • You need to enter the password from gui_rpc_auth.cfg into the dialogue which you can get from boincmgr's "File/ Select computer..." menu item.
  • You need to give the password as -p parameter in the command line when you start boincmgr.
  • There needs to be a readable copy of /var/lib/boinc-client/gui_rpc_auth.cfg, named gui_rpc_auth.cfg, in the working directory from which boincmgr is started.
  • You need to edit /var/lib/boinc-client/gui_rpc_auth.cfg to be empty, and restart the client, thus allowing unauthenticated control.
Any one of these on its own should be sufficient; you don't need a combination.

More info on remote control, but also relevant to local control on a multiuser system:
https://boinc.berkeley.edu/wiki/Controlling_BOINC_remotely

*) I'm not sure because I configure any new client on my own system right away to have remote control enabled ("remote" = from anywhere in my LAN). I never used the client with remote control disabled.
 
Last edited:

Howdy2u2

Senior member
Nov 12, 2017
338
168
96
#3
I went here: http://boinc.berkeley.edu/wiki/Installing_on_Linux
I found this:
./run_client --daemon; ./run_manager

I believe I had issues running it from the software manager and ended up going directly to the Berkley download..............but now that I read the site I linked to....it might be a mistake since it uses more memory AND does not use all of Linux's safety features.
 

lane42

Diamond Member
Sep 3, 2000
5,083
49
106
#4
There should be an icon for the Boinc manager, no need to run a command. You will see
the contents of the boinc folder are all over the place, it's a pain with the meta package. Also with
18.3 mint, it's a little buggy with mint. 1 is if you shut down Boinc it might not start back up- needing a restart.
Give the berkeley installer a try. I think it keeps all the files in 1 folder.
 

Pokey

Platinum Member
Oct 20, 1999
2,589
0
106
#5
Thanks guys.

As a last resort I rebooted the computer and Boinc Manager "suddenly" worked. :rolleyes:

I attached to Rosetta, an old favorite, and I am crunching away. I may be back when I attach to a GPU project, but I am good for now.

I avoided the Berkley installer (Wiki advice), but the software manager lists a lot of packages and my problem was which to install. I resorted to the mentality, "if one is good a bunch must be better", and went with the five I mentioned.
 

lane42

Diamond Member
Sep 3, 2000
5,083
49
106
#6
Ha, That's what I did :D
 
Aug 2, 2003
3,159
329
136
#7
GUIDE for BOINC on Linux Mint 18.3:

From the Welcome Screen click APPS, in search bar type BOINC, install "BOINC - Metapackage for the BOINC client and the manager"

Silly Goose!

I find BOINC runs in the background after that initial setup, and after a restart, I have an icon on the desktop to start the manager/GUI.
 

StefanR5R

Platinum Member
Dec 10, 2016
2,291
401
106
#8
I rebooted the computer and Boinc Manager "suddenly" worked.
Maybe a logout + login cycle was needed to apply rights to the boincmgr user for read access to the boinc-client directory.
 

Similar threads



ASK THE COMMUNITY

TRENDING THREADS