• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Linux Mint 20 and FAH

Pokey

Platinum Member
Oct 20, 1999
2,651
232
106
My personal instructions.

After installation of linux mint 20:
sudo apt update
sudo apt upgrade
reboot
(it is important to install all updates before installing video driver)
---------------
go to menu , administration, device manager to install nvidia driver then
reboot
----------------
sudo apt install ocl-icd-libopencl1 (already installed with Mint 20)
sudo apt install ocl-icd-opencl-dev (still required with Mint 20)

python-gtk2 Required for Mint 20
Where? Go to > and download and install:

FAHControl installed successfully after this file is installed.
----------------------------------
Install Fahclient and FAHConrol
----------------
This step may no longer be required:
cd /var/lib/fahclient
sudo wget https://apps.foldingathome.org/GPUs.txt

sudo service FAHClient restart
or reboot
-----------------------------------
Open up FAHControl:

Click the Configure button (on toolbar).
Select the Slots tab.
click on the cpu slot and then click on remove.
click on "add" a slot.
click on the radio button to add a GPU slot.
click OK.
You should see the new gpu slot in the slot list.
click on save.
A new task should download and start folding on one of your GPUs.
repeat the above to add another gpu slot for your second GPU.

Tweak as desired.

Configure>advanced>select cause preference

Configure>Expert Tab> Add Client control items:

client-type
advanced

next-unit-percentage
100

Again, this is what I use. YMMV
 
Last edited:

Desslok

Diamond Member
Jun 14, 2001
3,769
6
81
Thanks for the write up, unfortunately Mint keep freezing on my hardware so I went back to Win10 which is rock stable.
 

Desslok

Diamond Member
Jun 14, 2001
3,769
6
81
Most unusual...could you list your hardware? Perhaps try 19.3 if you get a chance...
Yes, it is odd.

Asus M5A97 LE R2.0

AMD FX-8350

16GB RAM

Nvidia 2070

1000w PSU

I will give 19.3 a try once things slow down at work.
 
Last edited:

StefanR5R

Diamond Member
Dec 10, 2016
3,641
3,910
106
The by far most likely cause of system freezes on Linux are bugs in 3rd-party drivers in kernel mode, i.e. kernel drivers which are developed outside of the mainline kernel source tree. That includes the NVidia graphics driver, and the VirtualBox drivers.

I recently updated from Mint 18.3 with version 3xx driver to Mint 20 with version 450 driver, on X99 and Z270 based systems with GTX 1080Ti. It's stable so far with a few GPU based DC projects. I haven't yet tried Folding@home since the update though. Besides, stability on 10 series doesn't mean it must be stable on 20 series GPUs...

Anyway; check in the driver manager of Mint 20 for availability of either a newer or an older driver version.

One other point: If the freezes happened when the GPU was utilized a lot, and if power draw under Linux was higher than under Windows (because of a higher performing Linux version of the GPGPU application), then another item to look into would be whether the PSU is up to the task.
 
  • Like
Reactions: Desslok

Desslok

Diamond Member
Jun 14, 2001
3,769
6
81
The driver update utility pointed me to the "official"Nvidia driver if I remember correctly. I will check again when I have time.

Thanks for the tip.
 

VirtualLarry

Lifer
Aug 25, 2001
49,234
5,469
126
I've run into issues using Linux Mint with more modern AMD platforms, and toggling IOMMU: Enabled or Disabled in BIOS/UEFI, sometimes fixes some of the issues that you might run into.
 
  • Like
Reactions: Desslok

gizmo23

Junior Member
Jun 22, 2020
7
19
41
This is v. useful, I was thinking about upgrading from 19.3. Initially I has a couple of niggles getting F@H and Boinc to work ok when I updated from 18, so was a bit cautious. This info makes me more confident, so thanks.
 

Mike_F

Junior Member
Jan 27, 2020
10
9
41
Peace to you all.
This is especially @StefanR5R or anyone else (biodoc) who are Linux wizzes.
I have a Mint box dedicated to F@H. It has two GPU's (potentially, three). They both fold with no difficulties, however, I can only get 'coolbits' active for one of them--not both. I have tried a lot of different commands, most of which leave me with a black screen and Mint in recovery mode. I now have a HDMI dummy plug, if that is useful to know. It hasn't helped as I thought it might.
Help!
Thank you in advance.
 

StefanR5R

Diamond Member
Dec 10, 2016
3,641
3,910
106
I can't help you with this particular issue, never explored this topic. (Each of my 2x/3x GPU computers have one and the same GPU model in them, as GPUs of different performance in a single host are awkward especially in competitions. Also, I use GPUs for computing only, and therefore run the fans at fixed speed instead of temperature control.)
 

biodoc

Diamond Member
Dec 29, 2005
5,654
910
126
I have a Mint box dedicated to F@H. It has two GPU's (potentially, three). They both fold with no difficulties, however, I can only get 'coolbits' active for one of them--not both. I have tried a lot of different commands, most of which leave me with a black screen and Mint in recovery mode. I now have a HDMI dummy plug, if that is useful to know. It hasn't helped as I thought it might.
Help!
Thank you in advance.
This usually works for me:
sudo nvidia-xconfig --cool-bits=28
reboot
If you just want fan control:
sudo nvidia-xconfig --cool-bits=4

I'm running MINT 20 with the MATE desktop.

If you want to try reducing heat by setting the power limit (watts) on the card(s), this is what I do on my dual 1080Ti rig to set the power limit to 180 watts on both cards:
sudo nvidia-smi -pl 180

If you want to set the limit to a specific GPU use the -i switch. For device id 1:
sudo nvidia-smi -i 1 -pl 180

If you reboot the computer, you'll have to rerun the commands.
 

Mike_F

Junior Member
Jan 27, 2020
10
9
41
Thank you both.
Stefan actually helped me out with the power limit settings some months ago. That works great, but I would still like a little more control on the second GPU.
biodoc, I will try the commands you that you mention. I'm pretty sure that I have already, but it is possible that I had the syntax wrong. I am MUCH more familiar with Windows.
I have had this box loaded with Mint for about a year now. I am basically satisfied if it runs stably, so I only mess with it occasionally to try to get it perfect. Over this time, I can get cool-bits working fine for one card, but not on both.
I do not game. These are running compute 24/7. In addition to setting a fixed fan speed, I like to be able to adjust the over/underclocking to tune for performance and/or efficiency as needed.
 

biodoc

Diamond Member
Dec 29, 2005
5,654
910
126
The GPU's are both nvidia--a 1070ti and a 2070, in case that matters.
Perhaps mixing a pascal and turing card in the same machine is causing a problem. My dual rigs are pascal/pascal and turing/turing.

sudo nvidia-xconfig --cool-bits=28 <----fan, overclocking/underclocking, and voltage control

Have you tried coolbits 12?
sudo nvidia-xconfig --cool-bits=12 <----fan, oveclocking/underclocking

There's things that you could do but I have no rationale for trying them. :)

1} uninstall the drivers and then reinstall
2) uninstall the drivers, shut down, then reverse the cards, boot and install the drivers.

I guess my point is this could be a big time sink with no guarantee of success.
 

Mike_F

Junior Member
Jan 27, 2020
10
9
41
"I guess my point is this could be a big time sink with no guarantee of success."
I hear that loud and clear.
Thank you.
 

ASK THE COMMUNITY