Linux DVD burning issues

Ken g6

Programming Moderator, Elite Member
Dec 11, 1999
At last I've gotten Linux to burn a DVD correctly! Four in a row, actually! But I'm having a few issues with wodim, and some other software:

1. Half the time, wodim fails to burn at all:
TOC Type: 1 = CD-ROM
scsidev: '/dev/sr0'
devname: '/dev/sr0'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Wodim version: 1.1.11
SCSI buffer size: 64512
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities   :
Vendor_info    : 'LITE-ON '
Identification : 'DVDRW LH-20A1S  '
Revision       : '9L05'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x001B (DVD+R)
Profile: 0x002B (DVD+R/DL)
Profile: 0x001B (DVD+R) (current)
Profile: 0x001A (DVD+RW)
Profile: 0x0016 (DVD-R/DL layer jump recording)
Profile: 0x0015 (DVD-R/DL sequential recording)
Profile: 0x0014 (DVD-RW sequential recording)
Profile: 0x0013 (DVD-RW restricted overwrite)
Profile: 0x0012 (DVD-RAM)
Profile: 0x0011 (DVD-R sequential recording)
Profile: 0x0010 (DVD-ROM)
Profile: 0x000A (CD-RW)
Profile: 0x0009 (CD-R)
Profile: 0x0008 (CD-ROM)
Profile: 0x0002 (Removable disk)
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Supported modes: PACKET SAO
Drive buf size : 1068032 = 1043 KB
Beginning DMA speed test. Set CDR_NODMATEST environment variable if device
communication breaks or freezes immediately after that.
FIFO size      : 12582912 = 12288 KB
Track 01: data  4447 MB       
Total size:     5107 MB (506:03.32) = 2277249 sectors
Lout start:     5108 MB (506:05/24) = 2277249 sectors
Current Secsize: 2048
HINT: use dvd+rw-mediainfo from dvd+rw-tools for information extraction.
Blocks total: 2295104 Blocks current: 2295104 Blocks remaining: 17855
Speed set to 5540 KB/s
Starting to write CD/DVD at speed   4.0 in dummy unknown mode for single session.
Last chance to quit, starting dummy write in    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
Errno: 5 (Input/output error), reserve track scsi sendcmd: no error
CDB:  53 00 00 00 00 00 22 BF 81 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 72 05 21 04 00 00 00 0E 09 0C 00 00 00 03 00 00
Sense Key: 0x1 Recovered Error, Segment 5
Sense Code: 0x00 Qual 0x03 (setmark detected) Fru 0x0
Sense flags: Blk 67108864 (not valid) illegal block length
cmd finished after 43.017s timeout 40s
wodim: Cannot open new session.
Writing  time:   48.656s
wodim: fifo had 191 puts and 0 gets.
wodim: fifo was 0 times empty and 0 times full, min fill was 100%.
At first I thought this was due to not using the -dummy option (see below), but it seems to be random.

2. wodim really burns a DVD when using the -dummy option. o_O I'm lucky I had the DVD set up like I wanted.

3. wodim and other burners insist on burning at my drive's maximum speed, 8x, even though I'd like to burn slower (4x) for archive purposes. Next time I'll try 2x and see if it burns at 4x.



Diamond Member
Jul 24, 2016
Try K3b it may work better then Wodim. Double your check if your SATA cable in plug in all of the way. And last, use decent media.


Diamond Member
Apr 2, 2002
I used the standard ubuntu tool since 10.04 and never fails. I think it is something like cdburn.

Ken g6

Programming Moderator, Elite Member
Dec 11, 1999
I finally did figure something out with Brasero and burning speeds, but it's weird. When I tried burning at 4x from an ISO, I got 8x. When I tried from some files, I got 2.4x. o_O

Edit: NVM, I must have selected 2.4x that time. I tried again, and 4x=8x. :rolleyes:
Last edited:


Jul 15, 2017
Just wanted to input my 2 cents worth, been such a long time since I actually had to burn anything not using DD, but Archlinux has some good documentation on the subject.

What most programs call anyway is mkisofs been a long time since I actually needed to burn something most times just use flash media nowadays. Only exception is getting things onto my system. I did buy an external bdrom drive just so I could put things on my system and file share.

Also wiki has a really good documentation on clones, and blu-ray playback explains things very well.