Lexar JumpShot (CF Reader) and Win2k Problems

iota

Junior Member
Jun 11, 2000
17
0
0
I just picked up a 64mb Lexar 8x CompactFlash card with USB enabled features. It included a 'JumpShot' cable (basically, the CF card has onboard USB interface, and the jumpshot cable just converts the CF cards connection edge to a USB plug, and lets the CF card talk to the PC over USB without a card reader) and a Win98 driver disk. I downloaded the Win2k driver and installed it without any problems (Win2k Pro OEM), and the unit works like a champ - I stick in a USB enabled Lexar CF card and a new drive appears with the contents of the card. Very slick.

However: When I pull the CF card out (there is no eject, just pull the card out -- the manual tells you its safe to pull the card out if no files on the CF are open, and all explorer windows are closed, etc etc (basically the same as a floppy -- don't pull it unless its done). the jumpshot thing has a indicator to let you know if it's "thinking" or not.) I get a Win2k 'Unsafe removal of device' error. I know that the removal was perfectly safe, because the card is fine, no files were open on it, and no windows were viewing its contents, plus the jumpshot light was in the 'not in use' position -- this all adds up to a perfectly safe removal. This error isn't a big deal, I can just hit OK, OR navigate through a few dialog boxes (about 3 or 4) each time I want to pull the CF out. However, this is quite a pain when I'm swapping cards out of the jumpshot, into my camera, and switching between the cards that I have. It becomes quite a hassle to have to cancel the 'unsafe removal of device' error every time, and I know that this error shouldn't be occuring.

I checked all the usual suspects for an option: device manager's entry for the device (actually, three devices: one under USB called 'Lexar JumpShot' (the connection cable), one for the Lexar USB CF card, and also one for the 'Generic Volume' that is created when the card is inserted (basically a virtual disk drive)), through the computer management snap-ins, through all the error and other dialogs I could find. No luck.
I also did my homework and searched through the web and newsgroups to see if someone else was having the same problem -- of course nobody was; the only similar errors I could find pertained to problems with USB drivers. I did send an eMail to Lexar Tech Support but I don't expect a response due to the holiday.

My machine is a ASUS K7V (I think? It's the slot A mobo), Athlon 750, 128ram, adaptec ultra2 scsi, 10k rpm 9.1gb ultra2 hdd, and some other things that aren't important to this. I do use other USB devices without any problems at all: my Logitech mouse is USB, as well as my Nomad II and the Nikon CoolPix 880's USB connection to the computer. None of these ever gives me any problems. I tried the VIA USB Filter update from a site that I foud, but it didn't help. I tried all the USB ports (the K7V comes with 4) and all of them have the same thing.

ANY help is appreciated GREATLY... I'm planning on going on a shooting spree and need to have quick access to my CF's so that I can take pictures, empty the CF's onto my HD, and keep shooting.

Thanks in advance. I know if I can't find an answer on the internet, I can find it on AnandTech Forums If I did not include enough information, please let me know by post or by eMail and I'll try to get more info for you.

jason
iota@ion9.com