Klipsch Promedia 2.1

Discussion in 'Home Theater PCs' started by Robert Brenner, Dec 9, 2017.

  1. Robert Brenner

    Robert Brenner Junior Member

    Joined:
    Dec 6, 2017
    Messages:
    11
    Likes Received:
    0
    Figured out a way to connect this device to my Sony Bravia. As simple as everyone thought it was, it wasn't. Not as much as a sound with audio cables. Tried every single possibility. Ended up using tv headphone jack....only problem was mono. One speaker. Using two splitters I ran the speakers together and it worked.
    I noticed bad sound from woofer. Upon inspection I found it was done. Replaced it with a slightly larger woofer. At first it didn't work. I took it apart. Everything was amazing....for a minute...now I have totally lost my speakers and only woofer works....WTF over?
     
  2. shortylickens

    shortylickens No Lifer

    Joined:
    Jul 15, 2003
    Messages:
    68,318
    Likes Received:
    4,225
    Pics would help.
     
  3. Robert Brenner

    Robert Brenner Junior Member

    Joined:
    Dec 6, 2017
    Messages:
    11
    Likes Received:
    0
    At the moment i have it all dismantled. It's hard to access behind the tv...so I've been looking inside for burns or damage and can't find anything obvious. Plugged into my phone to test, speaker's work, has to be in the amp.
     
  4. Robert Brenner

    Robert Brenner Junior Member

    Joined:
    Dec 6, 2017
    Messages:
    11
    Likes Received:
    0
    What would you like to see?
     
  5. Robert Brenner

    Robert Brenner Junior Member

    Joined:
    Dec 6, 2017
    Messages:
    11
    Likes Received:
    0
    By dismantled I meant not hooked up. Not taken apart