Keeping subtitles in encoded videos


Diamond Member
Jan 29, 2005
Wasn't sure where I could ask for this.

So normally I use VirtualDub to encode videos and use filters whenever I want to add or change stuff (like resizing, etc). I got a video with subtitles I've been trying to encode lately. I can encode it just fine, but the subtitles are gone after the encoding is done. The original format is .MKV, the resulting format is .AVI. There's a lot of automation in what I do and rarely look into the details, and I'm not that good with the technicalities behind the curtain.

I made some research with Google. Apparently, first of all, I need to extract the subtitles 'track' I want from the MKV video, which I actually did. I used a program called MKVToolNix that needed a separate plugin on its own (a GUI, namely: MKVExtractGUI2) which allows me to open MKV videos, find subtitles in it, and extract them as separate files in a destination folder. The extracted subtitle file has a .ASS format (Advanced Substation Alpha). What I then supposedly have to do is to simply go to the VirtualDub filter, select the manually-installed Subtitler 2 filter (downloaded separately) and then manually find and select the said extracted .ASS subtitle file, check the preview video if needed to see if it works, then just encode and voila, it should be set and done.

Well, that's where the problem shows up. I do have the Subtitler filter showing up in the list of VirtualDub filters. I select it, then go to the destination folder where the extracted .ASS subtitle file is... but nothing shows up in the window to select. Which means that the subtitler plugin does not 'see' (recognize) the format of the file and nothing shows up to actually select. I can of course click the scroll-down list and select "All Files" (all format) and 'force' the .ASS in, but it doesn't seem to work (unsurprisingly).

Then I checked in the MKVNix Tool to see if there's an option to change the format of the subtitle file just in case .ASS isn't working. Well, there's an option for that it turns out, called 'Export'. So instead of "Saving As" I just export as another format, there's a bunch of them. I tried them all one by one. And for each of them, the VirtualDub Subtitler filter just doesn't recognize any of them and I can't select them to add them for the encoding.

So I'm at an impasse.

How. The. Heck, am I supposed to keep subtitles from the source file to the encoding file (side note: it's non-English subtitles for the otherwise English movie, but I don't think that matters, it's just a 'track' with text I need to add to the video, or KEEP as it is in the original video).

Thanks for the help guys.


Diamond Member
Apr 20, 2013
I can't directly answer your question, but might be able to provide an alternative. I rip all my disks via MakeMKV and let my Plex Media Server transcode which keeps all the subtitles intact. No extracting/exporting/etc.

This would probably get better visibility/answers in the Home Theater PC's section.