Just Cause 2 Crashing

stahlhart

Super Moderator Graphics Cards
Dec 21, 2010
4,273
77
91
Got this game for free with my MSI cards; finally got around to Steaming it.

First time I played, it locked the PC up hard about 15 seconds into the intro cutscene. Second time I played it (after rebooting), I got about up to the point where you pull the guard down with the grappling hook... then the screen went all black. Game was still running, though.

Is this one notorious for stability issues, or should I look into my build for a problem?

Got Operation Flashpoint: Dragon Rising last night also (couldn't pass up the sale), and that runs wonderfully.
 

eLiu

Diamond Member
Jun 4, 2001
6,407
1
0
I have a crashing problem w/this game too. I've only seen it happen when i'm in an 'enclosed' vehicle (car, plane, helicopter). The screen freezes for a few seconds, which causes windows to reset the graphics.

windows pops up a msg that's like "graphics driver failed but we recovered it, yay." But then just cause 2 is all black. The game is still running; like I can shoot and drive around but I just can't see anything, lol.

I have no idea wtf is going on :( I thought it was heat related at first but my temps don't get above like 60C.
 

Zenoth

Diamond Member
Jan 29, 2005
5,196
197
106
I see in your sig that your system is over-clocked.

Try with everything at default frequencies and voltages.
 

gorcorps

aka Brandon
Jul 18, 2004
30,740
452
126
I see in your sig that your system is over-clocked.

Try with everything at default frequencies and voltages.

Bingo. I had the same problem with this game on my MSI GTX570 which has a small factory overclock. Once I brought that back down to where stock should be the crashes pretty much went away.
 

stahlhart

Super Moderator Graphics Cards
Dec 21, 2010
4,273
77
91
Crashes both at stock 2500K settings and overclocked. I can pretty much make it to that first building where you grapple down the guard, and then I lose it.

One thing I have noticed -- this game pushes my GPUs the hardest out of anything I have installed on this new build. Fans on the cards are going like mad, like I'm running a stress test, and then when the crash happens the fans shut right down. I don't even think Crysis pushes them as much. HL2 can run maxxed out for hours and I barely notice the GPU fans (granted, that's much older).

I can't find JC2's setting for disabling motion blur?

I'm also going to try disabling SLI and running one 560, mabye drop resolution some. I'm starting to this is a TWIWMTBP, BCATM problem with this game specifically.
 
Last edited:

gorcorps

aka Brandon
Jul 18, 2004
30,740
452
126
Crashes both at stock 2500K settings and overclocked. I can pretty much make it to that first building where you grapple down the guard, and then I lose it.

One thing I have noticed -- this game pushes my GPUs the hardest out of anything I have installed on this new build. Fans on the cards are going like mad, like I'm running a stress test, and then when the crash happens the fans shut right down. I don't even think Crysis pushes them as much. HL2 can run maxxed out for hours and I barely notice the GPU fans (granted, that's much older).

I can't find JC2's setting for disabling motion blur?

I'm also going to try disabling SLI and running one 560, mabye drop resolution some. I'm starting to this is a TWIWMTBP, BCATM problem with this game specifically.

Not the CPU overclocking, it's the GPU overclocking that's the problem. Some vid cards are overclocked by default and MSI does that a lot. Install MSI Afterburner, look up what the default 560 setting are on other cards and clock it back down to that.
 

stahlhart

Super Moderator Graphics Cards
Dec 21, 2010
4,273
77
91
Not the CPU overclocking, it's the GPU overclocking that's the problem. Some vid cards are overclocked by default and MSI does that a lot. Install MSI Afterburner, look up what the default 560 setting are on other cards and clock it back down to that.

Ah, okay -- I misunderstood earlier (sorry). I haven't messed with the clock settings on the cards at all, as nothing else has been acting up until now. They are MSI-overclocked.

I'll try this tonight. Thanks much...
 

gorcorps

aka Brandon
Jul 18, 2004
30,740
452
126
Ah, okay -- I misunderstood earlier (sorry). I haven't messed with the clock settings on the cards at all, as nothing else has been acting up until now. They are MSI-overclocked.

I'll try this tonight. Thanks much...

Yup. Can't say it'll solve all your problems, but it helped quite a bit for my overclocked MSI. Just Cause 2 is a great game but kind of a buggy port unfortunately. If you can get it to run properly it's a blast.
 

T101

Senior member
Oct 13, 1999
558
0
0
I have played through Just Cause 2 on three system, never even had a hitch running it. Probably the least buggy game I have played on a PC. This with CPUs and Graphics cards overclocked. First run was on Q6600@3.0Ghz with 8800GTX, then my second Q6600@3.0Ghz with a GeForce 470 overclocked to 750Mhz Core. And now finally on my Core i7 2600K @ stock with 2 x 470 in SLI overclocked to 700Mhz core.
 

stahlhart

Super Moderator Graphics Cards
Dec 21, 2010
4,273
77
91
I have played through Just Cause 2 on three system, never even had a hitch running it. Probably the least buggy game I have played on a PC. This with CPUs and Graphics cards overclocked. First run was on Q6600@3.0Ghz with 8800GTX, then my second Q6600@3.0Ghz with a GeForce 470 overclocked to 750Mhz Core. And now finally on my Core i7 2600K @ stock with 2 x 470 in SLI overclocked to 700Mhz core.

Go ahead, rub it in. :)
 

T101

Senior member
Oct 13, 1999
558
0
0
That was not what I meant to do. Just Cause 2 happens to be one of my all time favorite games. I just wanted to show that it can be run without problems. The only thing I can come to think of is that all my 470s have custom cooling solutions, so they run cooler than average. If downclocking helps solve the issue, try looking into improving cooling of the graphics card.
 

stahlhart

Super Moderator Graphics Cards
Dec 21, 2010
4,273
77
91
No worries. :) But I do think that you and gorcorps are onto something here.

Not sure what I could do to improve cooling -- it's a pair of Twin Frozr II 560s. I really don't think that I can improve on what MSI has done already, beyond perhaps remounting with better (?) thermal compound or (yikes!) water blocks. I'm going to have a side-mounted 140mm over them when I get the case modding done.

It's just bizarre. But the game looks like a blast, so I hope I can get this resolved.
 

Skunkwourk

Diamond Member
Dec 9, 2004
4,662
1
81
Crashed for me the first time. I think it worked fine after I turned off motion blur and SSAO.

Im pretty sure it was a video card issue for me.
 

stahlhart

Super Moderator Graphics Cards
Dec 21, 2010
4,273
77
91
Guess what it is for me? SLI.

Switch to a single card, no more crashing. I dedicated the second 560 to PhysX just for grins while I was in Control Panel, even though I know this game doesn't support it. Game runs fine.

While I was still running SLI, dropping resolution settings first, and then clocking down the GPUs to reference 560Ti settings second, had absolutely no effect, either instance -- still crashed in more or less the same place in the game.

So I guess now I get to figure out why this one game (so far) doesn't like SLI. Or just play it with one card, I guess.
 

T101

Senior member
Oct 13, 1999
558
0
0
Hmm. Since I dont have any 5xx series cards, I cant try it. Might just be nvidia drivers are yet buggy to run SLI with that particular game. What driver version are you running? and have you tried the latest beta drivers?

Regarding cooling, a side mounted fan that blows air over the cards make quite a difference on temperatures. Not that it seems it is temperature related anymore in your case.

It is kind of sad that you cant run it in SLI, because there are certain places in the game where you really need the power granted by SLI. Yet, I must say, running with one card still is ok. The game is just as fun :)

The only games I have that require more out of the computer than Just Cause 2 is Metro 2033, Red Faction: Guerilla, and Mafia 2.
 

Anteaus

Platinum Member
Oct 28, 2010
2,448
4
81
I had this problem when I started using my EVGA 570 GTX SC. When I would set the clocks to reference the problems went away. Oddly enough it only happened with this game. MSI Afterburner works great for adjusting clocks for situations like this. I chased this problem for a week before I finally realized it was Just Cause 2. I stressed tested my system into oblivion. JC2 just doesn't like OC gpus.
 

stahlhart

Super Moderator Graphics Cards
Dec 21, 2010
4,273
77
91
I'm running 266.44 drivers -- the ones on the disc that came with the cards. I will look and see what the current ones are, and will try those.

I'll take a second look for those graphics settings; mabye I just missed them -- thanks much...

Funny thing was that when I clocked the cards down here, it had no effect -- crashed in more or less the same spot in the game, but I was still running SLI. Does Afterburner change the clocks for both cards?
 

stahlhart

Super Moderator Graphics Cards
Dec 21, 2010
4,273
77
91
Downloading 270.61 drivers now. They specifically mention Just Cause 2 in the performance improvements, so mabye there's something in here that will fix the SLI problem. Will give it a shot; what the heck...
 

stahlhart

Super Moderator Graphics Cards
Dec 21, 2010
4,273
77
91
FIXED. It was the motion blur setting. It was still crashing with SLI after upgrading the drivers, so I went and found that setting (finally) and disabled it. Runs like a champ now.

Thanks, everyone, for the help!