Issue with USB Key not mounting to drive letter

TurboCooler

Member
Jun 1, 2015
25
0
6
I have Windows 10 with the latest updates

I have used this USB on this machine for over a year. Other USB Keys mount fine, just not this particular one.

Today, I put in the key, I see from the Windows 10 Eject Icon that it is there but has no drive letter assigned.

I did some searching and came across this article
http://searchenterprisedesktop.techtarget.com/tip/What-to-do-when-USB-flash-drives-refuse-to-mount-in-Windows

I downloaded the recommended tool USBDeview

The website for the utility says that it works with Windows 10. I installed it and followed the article to delete the reference to the USB Key. Rebooted as recommended, and still nothing. I can see from the utility that it is going into the database, but is never assigned.

Yes, the key works on other computers and other Windows 10 machines, just not my main computer.

The work around was to get another USB key and mount them both on another PC and copy the files over. That worked.

I would like to however understand how to fix this problem. I assume something in some database or ini file is corrupted and would like to fix it.

Anyone have any ideas?
 

Elixer

Lifer
May 7, 2002
10,376
762
126
Open up disk management, and just assign a drive letter to the device.
 

TurboCooler

Member
Jun 1, 2015
25
0
6
My apologies, I work as a part-time EMT and this heat has made it difficult for some in my community so I have been on more calls than I ever expected.

Back on topic. Each method presented has the same problem.

diskpart sees no volume on the USB Key and disk management shows no allocated space. This is on my particular windows 10 computer. On any other computer, it works as you would expect.

Should I simply try to reformat the drive on the computer where the volume cannot be seen?? (After obviously backing up the USB Key)
 

Elixer

Lifer
May 7, 2002
10,376
762
126
It works on one machine, but not the other?
Did you try different USB ports on the machine it don't work on?

What USB flash drive is this specifically?
 

tcsenter

Lifer
Sep 7, 2001
17,962
94
91
Yes if you already have the data backed up somewhere then try deleting the partition, create a new one and then format. Sounds like you could have a glitchy USB port. Check for BIOS update for the system/board as well. Flash drives are cheap, might want to consider tossing and replacing it.
 

TurboCooler

Member
Jun 1, 2015
25
0
6
It works on one machine, but not the other?
Did you try different USB ports on the machine it don't work on?

What USB flash drive is this specifically?
It works any other machine but this particular one. It is a Cruzer 32gb thumb drive.
 

TurboCooler

Member
Jun 1, 2015
25
0
6
Yes if you already have the data backed up somewhere then try deleting the partition, create a new one and then format. Sounds like you could have a glitchy USB port. Check for BIOS update for the system/board as well. Flash drives are cheap, might want to consider tossing and replacing it.
I tried different USB Ports. I have a Asus X99 Deluxe MB. Yes, USB keys are cheap so getting a new one may be the answer but I was hoping there was different solution.
 

tcsenter

Lifer
Sep 7, 2001
17,962
94
91
I have seen this same scenario once or twice as well. i.e. Flash drive works on every other PC except one, other flash drives work fine on affected PC, USB ports seem to be fine. I'm pretty sure I used diskpart to delete the partition (-clean), unplugged and replugged, used diskpart to create new partition and formatted. IIRC it worked fine after that (on other computers, too).
 

ASK THE COMMUNITY