• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Question Is it normal for the PC to try to goto sleep while running Prime?

motojeff

Member
Mar 21, 2002
114
0
76
Hi,

I have my LCD set to go off after 10 minutes of idle and my PC to goto sleep after 30 minutes of idle.
While running prime, my LCD kept trying to goto sleep, so I'd wiggle my mouse to get it to not do that.
After an hour of running prime OK, I left the room to let it keep running (no AVX). About 2 hours later I came back
and my PC had shut completely down.

Should the PC think it's idle when running something like Prime and try to turn off the LCD?
Did it try to goto sleep and couldn't cause Prime was running so shutdown?

Any help appreciated.
 

VirtualLarry

Lifer
Aug 25, 2001
49,178
5,453
126
One way to know for certain, check your Power Plan settings, and Monitor Sleep settings, and if they are set to shut the monitor off after 15 minutes, and to put your PC into sleep mode after an hour or two, change them to "High Power Plan", "Sleep After" to "NONE", and "Monitor Sleep" to NONE, and see what happens.

If your LCD still shuts off, and/or PC is off, then your PC is having hardware (probably PSU, possibly GPU) issues.
 

motojeff

Member
Mar 21, 2002
114
0
76
I took off my OC and ran prime with windows 10 setup to shut off the LCD after 10m of no activity and put the PC to sleep after 30m. Both happened. I guess Prime does not tell w10 not to goto sleep while running.
 

samboy

Member
Aug 17, 2002
186
24
81
I have the same problems with Windows 7 & 10. For whatever reason a 100% CPU load is not enough for Microsoft to consider "active" and will put the computer to sleep in the time you have set.

Very annoying....... you do a large compile and leave the computer only to find that Windows has gone to sleep before the job has completed!

Any bit of network activity seems to stop the computer from going to sleep.
Microsoft needs to give people more control.........
 

VirtualLarry

Lifer
Aug 25, 2001
49,178
5,453
126
Just shut off the "Sleep After" setting, and the PC shouldn't go to sleep. Monitor sleep, I leave enabled, saves power when I walk away from the PC.

In Win10, if you hit Winkey+L (Lock Workstation), the lock-screen will go to monitor sleep in like 3 minutes, rather than the normal default time-out.
 

ASK THE COMMUNITY