I'm not getting HD audio anymore - nVidia drivers

Discussion in 'Home Theater PCs' started by Khartago, Dec 7, 2016.

  1. Khartago

    Khartago Junior Member

    Joined:
    Dec 7, 2016
    Messages:
    2
    Likes Received:
    0
    Hi all,

    I have an Asus laptop that I have been using as a HTPC for more than 3 years now, the GPU is a GeForce GT 635M (2GB).

    And it was all fine until one day all of a sudden I played a DTS-HD MA movie and it had no sound coming (which I had no problem playing before), I use Kodi, so I went to check the settings and it was all good for bitstream in WASAPI, then I play some movies with only DTS and DD and it did came sound, so then I went to playback devices to check everything and then I noticed that in supported formats neither DTS-HD MA nor Dolby TrueHD appeared any longer.

    I don't know what to think of this, the laptop came with Windows 8, then I upgraded to 8.1, then Windows 10 and all was fine after every update, so I don't think it's the OS.

    I have been troubleshooting, I uninstalled the drivers several times, I went back down to the 355.60 driver and nothing seems to happen. My receiver is a Pioneer VSX-524-K, I tried changing the HDMI cable, I tried switching inputs, I even checked the Blu-Ray player directly to see if it was the receiver, but it played a DTS-HD MA movie just fine (with the logo and everything).

    It's driving me nuts, some help would be appreciated.
     
  2. Loading...

    Similar Threads - audio anymore nVidia Forum Date
    Nvidia Shield TV and Big Red X showing Home Theater PCs Mar 29, 2016
    Utility to change default audio track? Home Theater PCs Feb 5, 2016
    Xbox One HDMI in audio delay Home Theater PCs Dec 29, 2015
    Similar Windows/Linux software to AirServer to (Mira)cast Android phone audio to PC? Home Theater PCs Dec 14, 2015
    How do I get back HDMI audio on my receiver after 4k upgrade? Home Theater PCs Nov 28, 2015

  3. Alamat

    Alamat Senior member

    Joined:
    Apr 30, 2003
    Messages:
    620
    Likes Received:
    1
    I have run into the same problem ever since Win 10. I have even put in a separate sound card but still pretty much the same problem.
    Hopefully, someone will chime in.
     
  4. Murloc

    Murloc Diamond Member

    Joined:
    Jun 24, 2008
    Messages:
    5,203
    Likes Received:
    42
    are you getting DTS written on the AVR screen when playing DTS files as usual?
     
  5. Khartago

    Khartago Junior Member

    Joined:
    Dec 7, 2016
    Messages:
    2
    Likes Received:
    0
    Hi Alamat, I managed to discover the solution, I'll share it in case it helps anyone else having this problem.

    What I think caused the issue in the first place was me updating the drivers after I added a SSD to my PC, I cloned the disk to the SSD and even so everything worked, I decided to update some drivers and programs, including the Nvida Drivers.

    I did the usual installation, no custom installation as I should have, so after various tryings uninstalling and installing the drivers even I eventually noticed that in the custom installation I wasn't getting installed the HD Audio driver.

    Later I did some more research and I found out that the HD Audio driver would only appear if you have the Receiver connected to the computer in that exact moment (I don't understand why), and so I did it, and indeed it appeared, and once I installed it everything worked wonderfully again.

    Note that I had the image only displaying on the TV.
     
    #4 Khartago, Feb 4, 2017
    Last edited: Feb 4, 2017