If deep sleep mode is enabled Please plug the cable.

Discussion in 'Motherboards' started by zagood, Feb 8, 2011.

  1. zagood

    zagood Diamond Member

    Joined:
    Mar 28, 2005
    Messages:
    4,103
    Likes Received:
    0
    Solved problem, thought I'd post if anyone else with a Realtek onboard nic runs into the same problem. This was on a MSI H55-G43 with Win7 x86.

    Had a problem with one of the home pcs today, came out of sleep (S3) and there was no internet. Check that...no network controller at all. Didn't show up in hardware manager, nothing. Restart, same thing. Reinstall drivers, same thing, with a great error message, "If deep sleep mode is enabled Please plug the cable." Checked BIOS, onboard LAN is enabled. Reset CMOS. Standard troubleshooting.

    After an hour of digging through forums etc. and trying different suggestions, found a real stupid one..."I found the fix: power down and unplug the PC. Do a little f---ing dance, power back on and it works." Apparently that's what "please plug the cable" means.

    Aaaaaand, that solved it.

    Apparently these nics have a problem waking up from "deep sleep" and you need to nudge them out of it. To keep them from getting to this state:

    - Go to Device Manager
    - Select Network Adapters
    - Select Realtek PCIe GBE Family Controller
    - Select Power Management
    - make sure "Allow the computer to turn off this device to save power" is unchecked
    - Select Advanced
    - under Green Power, select Disabled.

    I think the Green Power one is probably unnecessary but not taking any chances.

    Anyway, hope this helps anyone who may run into the same problem. This isn't 100%, there are threads out there where this has been tried and still doesn't work.
     
  2. johnnyblaze430

    johnnyblaze430 Junior Member

    Joined:
    Nov 11, 2012
    Messages:
    3
    Likes Received:
    0
    The RealTek Network Adapter/Controller was not found.
    If Deep Sleep Mode enabled Please Plug the Cable"***********

    Ok so you posted originally..."do a dance" and plug it back in ? huh i didnt get that... haha novice with computers here so I am still learning.

    This happened to my Dell Inspiron N 4110 - I-5 processor-Win 7 64 bit, 6 gb Ram, 575 GB HD.

    this all started when I went into BIOS to disable an "HD Password" that my nephew put in. Upon disabling it...i wasnt sure how to clear it out due to the way you can modify the values...so i just hit "load system default settings"....right after that i go back into my OPsys and bammm...NO INTERNET. no wireless...im like "huh??wtf?""

    I have been from forumn to forumn, everyone saying the same thing.
    i have even taken these steps..
    1) Removed RAM
    2) Disconnected Battery
    3) Disassembled the entire machine- went to ethernet card and disconnected that....
    4)went to bios upon start up and made sure onboard LAN settings were enabled.
    after 2 hours of having this machine apart....and put it back together..IT still does not come out of that mode and LAN or network adapters do NOT show up in device manager whatsoever...i still am not alowed to install anything too. i get an error saying " there is no device found, realtek was unable to install the driver" .........

    so when you posted this above you again, did say the answer was to....."do a little f*** dance" what does that mean? i saw the post that originatyed from and i dont get it. what cable is it saying to plug in lol? please help!!!!!!!
    thanks so much
    hopefully your my answer!!!
     
  3. tweakboy

    tweakboy Diamond Member

    Joined:
    Jan 3, 2010
    Messages:
    9,498
    Likes Received:
    1
    Holy cow 17k views ? why ? Glad you solved it but, sleep mode does have bugs, I blame it on that.

    My dad loves putting his computer to sleep. When it wakes up he has no internet sometimes, not all the time, just sometimes. Rarely, but it does happen. He has Gigabyte micro board and Sandy Bridge 2600k . Also once in a while, he gets problems like apps problems or small computer issue which requires a restart.

    Most of time its ok, but it does happen. Its pretty liable, but not 100 percent reliable.
     
  4. GPz1100

    GPz1100 Senior member

    Joined:
    Jun 10, 2001
    Messages:
    341
    Likes Received:
    0
    I remember many years back (mid 90's?), servicing some compaq laptops. Cust complaint was the machine would sometimes not wake up. Upon duplication of issue and contact with compaq, turned out this particular model had similar issues with sleep mode being buggy. Ironic, such issues still around 15+ years later.

    The OP's solution does make sense. Powering off the device still results in some circuitry being powered. Trick is to flip the switch on the p/s (if yours has one), then press the power button on the computer. This should discharge and residual charge present and power down the device completely. Or, remove the power cord and wait or press power button (while unplugged).

    On my current machine (q9550/p5kdeluxe), I use sleep mode extensively. On occasion, upon wake, the BT connection between keyboard and dongle is severed, on rarer occasions, wireless link between trackball (logitech trackman) and receiver is also severed.
     
  5. Harvey

    Harvey Administrator<br>Elite Member
    Administrator

    Joined:
    Oct 9, 1999
    Messages:
    35,036
    Likes Received:
    0
    By "do a little f*** dance," I think he meant that, after unplugging the machine, give it a little time for the PSU and all onboard caps to discharge fully. 30 seconds to a minute should be enough. You can accomplish the same thing with a mechanical power switch if your PSU has one.

    OTOH, if you're going to do a little dance, be sure to turn to the right, instead of the left. Doing the same dance turning left is a rain dance that could damage your machine and your carpet or hardwood floor. For further information, consult "The Ooga-Booga Mystery Oil Handbook of Computer Repair and Maintainance." ;)
     
    #5 Harvey, Nov 11, 2012
    Last edited: Nov 11, 2012
  6. johnnyblaze430

    johnnyblaze430 Junior Member

    Joined:
    Nov 11, 2012
    Messages:
    3
    Likes Received:
    0
    haha very funny....well since your a replier here is what i went thru so far after everything originally stated.
    1) Bought New NIC card and replaced.
    2)Turned laptop back on after reassembly....STILL can not detect an ethernet controller. getting same message
    "The RealTek Network Adapter/Controller was not found.
    If Deep Sleep Mode enabled Please Plug the Cable"

    Iwent pretty far with this it seems. I dont think anyone else has reportedly gone any further. So if i still have not solved this issue... heres my ultimate thought

    1) MB issues....replace with new??? (remember my pci supported chipset IS working and detected and graphics controllers)
    2) Would BIOS have a hidden setting to manipulate a tick to "wake up my network adapter?
    i have reformatted this version clean once. also have ensured onboard LAN in bios IS enabled.
    im so confused but have a hunch it is more an issue that is NOT hardware related and the MB is opkay....there was no power surges or anything like that...reminder this all started when i disabled a BIOS password my nephew put in and when i exited BIOS i accidentally hit "load default settings" .....when i restarted the pc...i notice no network adptr functions/
    thought suggestions/?
     
  7. johnnyblaze430

    johnnyblaze430 Junior Member

    Joined:
    Nov 11, 2012
    Messages:
    3
    Likes Received:
    0
    ok guys.....so its fixed...i dont know how it fixed it...but aparently i went into BIOS and selected "load defualt set up " and exited. when windows started...taskbar notification area litt up like the chrysler building with flash messages "loading updating drivers"
    i went directly to device manager...what was there? "network adapters". i didnt even need to buy the new NIC card like i specified earlier... i also almost took another techs advice that is what a short in the mainboard...alsmot had to buy a mobo...but persistence solved it!!!! thanks for you help ...aparently the most suyperfluous setting took it out of deep sleep mode
     
  8. techs

    techs Lifer

    Joined:
    Sep 26, 2000
    Messages:
    28,567
    Likes Received:
    0
    I thought I would ressurrect this thread since I have the same problem.
    Now its months later and there is still no permanent fix, though the steps to reinitialize the network controller are better understood.

    The problem persists in Windows 8 btw.

    I can turn off the power switch on my power supply or unplug the power cord for about ten minutes and the nic reactivates. I can also Load System Defaults in the bios, or Reset Configuration Date in the bios. System Defaults requires me to reset a number of settings and Reset Configuration Data works only about half the time.

    I have tried three more bios updates and none fixes the problem.

    So, basically, I have given up. I have installed an internal nic card and just disabled the on board nic.