i7 5820K clock behavior question

bystander36

Diamond Member
Apr 1, 2013
5,141
10
106
#1
Today, I decided to take a look at HWMonitor for the first time in about a week and noticed some change in behavior. The clocks of the cores are no longer increasing in increments. They either are at full idle or full clock speeds and nothing in between. This is not how it looked a week ago and before (the system is only a couple weeks old). I looked into the BIOS and the dynamic clocks, and EISTE settings are enabled. I do not know why this is the case now, other than the possibility that an Intel driver update occurred in the last couple days.

Is this normal behavior?
 

myocardia

Diamond Member
Jun 21, 2003
9,223
0
71
#2
It's normal behavior, if you're using Windows 7, and you have changed your Windows power settings from Balanced, to High Performance.
 

bystander36

Diamond Member
Apr 1, 2013
5,141
10
106
#3
Ah, I did install some drives recently and had some performance setting changes made at the time. I'm on Win 10, but they likely have a similar feature I turned to performance.
 

bystander36

Diamond Member
Apr 1, 2013
5,141
10
106
#4
That was it. My Samsung m.2 drive had an option for high performance, which I choose and it not only changed the drive settings, but the processor settings too.
 

bystander36

Diamond Member
Apr 1, 2013
5,141
10
106
#5
Wow, I ran SuperPi to compare results between performance and balanced, and it was about 10% faster in performance mode. I'll see what happens with 3Dmark Firestrike.

Firestrike only saw a ~250 physics score boost. I have a feeling this matters more for single threaded programs as the load changes from core to core. I noticed in SuperPi, the clocks kept showing up a little below load as it changed from core to core, because they were idle prior to the switch.
 
Last edited:

moonbogg

Diamond Member
Jan 8, 2011
9,744
22
126
#6
My clocks were stuck at full speed in windows 10 after installing 850 EVO drive. When power settings were changed to performance for the SSD, it changed the CPU minimal state to 100% and it never throttled down. I changed it back to 5% manually and now it throttles as expected.
If yours is still throttling down even with power settings at high performance, then I wonder what your minimal CPU state is set to and what other power settings could have an effect on CPU throttling. I thought the only pertinent setting was the minimal CPU state under power settings.
 

bystander36

Diamond Member
Apr 1, 2013
5,141
10
106
#7
My clocks were stuck at full speed in windows 10 after installing 850 EVO drive. When power settings were changed to performance for the SSD, it changed the CPU minimal state to 100% and it never throttled down. I changed it back to 5% manually and now it throttles as expected.
If yours is still throttling down even with power settings at high performance, then I wonder what your minimal CPU state is set to and what other power settings could have an effect on CPU throttling. I thought the only pertinent setting was the minimal CPU state under power settings.
It's not that. I ran the tests at 4.375Ghz. It's a single threaded benchmark. With the new load balancing, the thread jumps from one core to the next after about 1 second. Since only 1 core is in use at any given time, the rest of the cores at at 1500Mhz. When it swaps to a new core, the core doesn't go straight to 4.375Ghz, and instead, stops at 4.125Ghz (and perhaps some other slightly lower clocks) before reaching 4.375Ghz. That moment of time before it hits full clock makes my system perform a little below optimal performance.
 
Last edited:

moonbogg

Diamond Member
Jan 8, 2011
9,744
22
126
#8
It's not that. I ran the tests at 4.375Ghz. It's a single threaded benchmark. With the new load balancing, the thread jumps from one core to the next after about 1 second. Since only 1 core is in use at any given time, the rest of the cores at at 1500Mhz. When it swaps to a new core, the core doesn't go straight to 4.375Ghz, and instead, stops at 4.125Ghz (and perhaps some other slightly lower clocks) before reaching 4.375Ghz. That moment of time before it hits full clock makes my system perform a little below optimal performance.
So you changed your power settings to performance and your CPU still throttles down? What settings did you change to fix your CPU issue?
 

bystander36

Diamond Member
Apr 1, 2013
5,141
10
106
#9
So you changed your power settings to performance and your CPU still throttles down? What settings did you change to fix your CPU issue?
It wasn't so much of an issue, just different behavior than before. Before it down clocked more aggressively when not at load, and after, the clocks were either at idle or full clocks and tended to stay at full clock a lot more often.

Under Power management in the control panel, go into the advanced settings and change settings of your power plan and choose performance.

I was just surprised at how it can affect performance a little bit. It was really impressive with Super Pi, where it was 10% faster under performance mode. In 3dmark Firestrike, it saw about a 1.5% improvement on physics, so it likely won't be a major improvement for the most part.
 

moonbogg

Diamond Member
Jan 8, 2011
9,744
22
126
#10
I was playing with those settings recently, but I think it was in windows 8.1 right before I switched to 10. Under 8.1, if set in performance mode, the CPU is always at 100% full clocks and never throttles, at least for me it was. I'll check it out under windows 10 and see how it does.

I just tried it real quick and it stays pegged 100% on performance mode. I'm wondering how you have performance mode activated while still being able to have CPU throttling, even if its an off/on kind of thing with no mid point in speed. I would like to have this kind of CPU behavior since its better than half ass CPU speed at certain times but full speed other times.
 
Last edited:
Apr 15, 2001
12,957
0
0
#11
I was playing with those settings recently, but I think it was in windows 8.1 right before I switched to 10. Under 8.1, if set in performance mode, the CPU is always at 100% full clocks and never throttles, at least for me it was. I'll check it out under windows 10 and see how it does.

I just tried it real quick and it stays pegged 100% on performance mode. I'm wondering how you have performance mode activated while still being able to have CPU throttling, even if its an off/on kind of thing with no mid point in speed. I would like to have this kind of CPU behavior since its better than half ass CPU speed at certain times but full speed other times.
yeah I dont understand that either as I am at full turbo speed and full voltage the whole time if I choose "high performance". same thing when I had my 2500k too.
 

bystander36

Diamond Member
Apr 1, 2013
5,141
10
106
#12
Win 10 doesn't hold you at full speed like Win 8, but it does run at full speed a lot.
 
Apr 15, 2001
12,957
0
0
#13
Win 10 doesn't hold you at full speed like Win 8, but it does run at full speed a lot.
um I am on Win 10 and it does the same thing as Win 8.1 and even Win 7 did. again I go right to full turbo and full voltage and stay there on high performance.
 

bystander36

Diamond Member
Apr 1, 2013
5,141
10
106
#14
um I am on Win 10 and it does the same thing as Win 8.1 and even Win 7 did. again I go right to full turbo and full voltage and stay there on high performance.
I assume you have a browser open. Basically, the browser will run a few threads, and if something is happening on the core, it goes to full power.
 
Apr 15, 2001
12,957
0
0
#15
I assume you have a browser open. Basically, the browser will run a few threads, and if something is happening on the core, it goes to full power.
I closed everything including my browser and it still goes right to 4.3 and 1.22 volts when using high performance. I looked at it for several minutes straight and it stays at that.
 

bystander36

Diamond Member
Apr 1, 2013
5,141
10
106
#16
I don't know. I can only assume something is running in the background that is using just enough processor power to kick it in to full clocks.
 


ASK THE COMMUNITY

TRENDING THREADS