HTPC having issue with playback of certain movies

Sep 3, 2008
117
0
81
#1
Hello all,

My HTPC is an HP laptop with an i5 480M Arrandale, 4 gig of RAM and Intel HD Graphics. I have hundreds of DVD rips (VIDEO_TS folder) that play fine with Kodi and/or MPC-HC with madvr. All default settings except I have set Kodi "Adjust display refresh rate" set to Always. This is hooked to a 4K TV, but my problems exist even when not hooked up to the TV and using the laptops native display. Even if I set this to Off the issue still persists.

I have started picking up some bargain bin Blurays and some for my son as well. All of the non-animated bluray rips play just fine. Examples are: Gravity, Sin City, Dark Shadows, there are plenty more.

The problem I am having is with animated blurays. Examples are: Wall-E, Nemo, Minions. I have the issue with all three of these on my HTPC laptop, however they play fine on my desktop PC. An old core2duo with a GTX960.

The best I can explain the issue is that it will appear at any point in the movie and appears as a horizontal band across the screen. Everything within the band is scrambled looking while the rest of the screen remains fine. This will come and go at various times throughout the movie.

I have tried messing around with the refresh rates of the intel drivers trying 23, 24, 60, etc... nothing makes a difference. The odd part is that other animated films play fine (Big Hero 6, Ponyo, Hotel Transylvania)

At first I thought the issue was the rips themselves, but since they play fine on my desktop I figure there must be some setting or incompatibility on the HTPC laptop.

Any ideas. The problem movies have the problem whether I use Kodi or MPC to play them.

Thanks,

Maiyr
 
Oct 16, 1999
10,497
0
0
#2
How does WMP handle the problem movies? I have a few old rips that the LAV filters built into MPC will choke on. My problem is different, it's more of a cadence problem that makes them extremely choppy, but disabling MPC's built in mpeg decoder and letting it default to the one built into Windows fixes them.

The other thing, some animated movies will do things that can throw off 3:2 pulldown. That's probably not it here, but it's something else to look at if you keep running into dead ends.

Edit: Just looked at this again, you're having problems with Bluray and not DVD rips. So it's not the first thing and might be the second. Look for any deinterlace\3:2 pulldown\inverse telecine options. Also you could try using madVR or Haali's renderer in MPC and see if that avoids the problem, which I'm going to assume lurks somewhere in Intel's drivers and the default EVR.
 
Last edited:
Sep 3, 2008
117
0
81
#3
Gonad,

I tried your suggestion of using MPC with the Default System renderer instead of madvr. On the first movie I tested it looks like that did the trick. I'll check the others tomorrow and report back. I'll give WMP a try as well.

Thanks for the feedback.

Maiyr
 
Oct 16, 1999
10,497
0
0
#4
Glad you made some progress. If it turns out they only act up with madVR it might be worth contacting the developer. He seems to be pretty active on it. Or try the latest version if you haven't, the one from last week lists this in the changelog:
added a workaround for glitch problems with shaky 3D GPU drivers
 
Sep 3, 2008
117
0
81
#5
Gonad,

Thanks a ton man. You nailed it. All of the movies I was having the problem with play fine when using MPC with the default system renderer. So at least that gives me an option for when Kodi isn't happy with the movie. At your suggestion I may post on the madvr forums as well.

Thanks,

Maiyr
 
Sep 3, 2008
117
0
81
#7
OK, a little embarrassing that I didn't find this more easily, but I figured it out....

I found this because I installed Media Center to see how it worked and as I went through the settings I realized when I had the problem. So then I went back into Kodi and yep, same issue.

Hardware Acceleration ! With this turned on I get the issue I was having in certain movies. Turn it off and the issue is gone. I guess it was just one of those things that I thought should of course be on so I kind of ignored it. On my main PC having this on causes no issues (maybe due to a discreet video card), but on my HTPC (Intel HD graphics) the acceleration causes the problem.

Anyway, glad it is all good in HTPC land again. Was a pain playing some movies in Kodi and others in MPC.

Thanks,

Mayir
 

Similar threads



ASK THE COMMUNITY

TRENDING THREADS