• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

How to stop android from saying "no internet" on wifi?

Red Squirrel

No Lifer
May 24, 2003
60,616
8,978
126
www.uovalor.com
I've been blocking my phone from accessing google IPs because I noticed lot of data leaking and just trying to make things more secure, but as a result it fails the "internet check" because it's connecting to their own servers to check that. Is there a way to just disable that feature altogether? I always found it annoying anyway because there are some networks I do connect to that have no internet and it gives more trouble, such as not wanting to automatically reconnect, or blocking all local traffic. That is the issue I see now, I can access internet sites but not local ones. Is there a way to just disable that altogether so it works normally?
 

Red Squirrel

No Lifer
May 24, 2003
60,616
8,978
126
www.uovalor.com
Unfortunately I don't seem to have that option listed, as is my luck with this sort of stuff. I wonder if it requires the phone to be rooted. Suppose I should lookup how to do that as it seems lot of more advanced stuff requires it.

Suppose another solution is to figure out what Android does to detect internet, such as if it connects to an IP or a host and then just redirect that traffic to a local server. Downside is if it's encrypted I won't really see what it's doing, but maybe just having that IP accessible is enough, if it's simply doing a basic request looking for a server response.
 

mxnerd

Diamond Member
Jul 6, 2007
6,101
876
126
Just rooting probably won't work. You probably need to find if there is after market firmware for your device and replace the factory firmware.

It's always very risky if you didn't do it properly. If you have no experience doing it before, watch a lot of tutorials on Youtube first.

Check out XDA forum https://forum.xda-developers.com/

==

Don't know if we can use proxy, local DNS or any firewall APPs to block Android accessing those (burn-in?) IP addresses or FQDN. We need to find them out first, however.
 
Last edited:

Red Squirrel

No Lifer
May 24, 2003
60,616
8,978
126
www.uovalor.com
From what I read, my phone (DTEK50) does not support 3rd party firmwares, so I'm kind of out of luck there.

Next phone I buy I will do some research to make sure it actually supports 3rd party firmware, then that will solve the whole security thing as a whole as I can find some custom firmware where they stripped out all the Google stuff, hopefully.

Figured I could at least just block all the google/other suspicious IP ranges (I keep adding them as I find new ones) to at least gain a bit of privacy back. Basically I check my firewall to look for any weird traffic then lookup the IP owner and full subnet and block that. Phones are leaky.
 

mxnerd

Diamond Member
Jul 6, 2007
6,101
876
126
Just checked my Samsung smartphone access log with my Pi-Hole setup. It at least logged the following Google stuff

Code:
firebase-settings.crashlytics.com

settings.crashlytics.com

firebaseinstallations.googleapis.com

offlinepages-pa.googleapis.com

clientservices.googleapis.com

www.googletagmanager.com

www.googletagservices.com

www.gstatic.com
Pi-Hole of course will not log IP address if the device does not query FQDN. No firewall running in my environment.

The problem blocking any of these could cause service problems. Only try and error can tell.
 

Red Squirrel

No Lifer
May 24, 2003
60,616
8,978
126
www.uovalor.com
Yeah some stuff won't work, like well anything by Google. I removed the block for now, will need to figure out the wifi situation better so that it stops thinking there's no internet. It would not be so bad except when it goes into the "no internet" mode, I can't connect to anything local, it blocks it for some reason. Can still connect to internet sites though.
 

Red Squirrel

No Lifer
May 24, 2003
60,616
8,978
126
www.uovalor.com
Actually I wonder if it uses a different DNS server when it goes into "no internet" mode. That would explain why I can't access my local stuff if it defaults to a different DNS instead of my own. May have to experiment more with that.
 

ASK THE COMMUNITY