• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

How To Disable HT-Assist on Opteron 6200 Series

Collider

Senior member
Jan 20, 2008
514
4
81
I'm wondering if its possible to disable HT-Assist feature on Opteron 6200 series CPU. I've searched around BIOS and around the web but can't find anything.

Reason why I would like to disable it is that Opteron 6200 series CPUs should have 16 MB L3 Cache, however 4MB is reserved for HT-Assist, so only 12MB L3 is OS usable. For my use case it would be beneficial to gain additional 4MB L3.

Wondering if anyone has figured out how to do this. Thanks.

A couple of links detailing the issue:
https://superuser.com/questions/1266715/missing-l3-cache-in-opteron-6274-on-windows-server
https://www.supermicro.com/support/faqs/faq.cfm?faq=26991
 

LTC8K6

Lifer
Mar 10, 2004
28,523
1,573
126
It seems to be called "Probe Filter" in the BIOS settings? Can't you disable that?
 

Collider

Senior member
Jan 20, 2008
514
4
81
Yeah HT pulls up a bunch of HyperThreading results.

Can't find anything like probe filter in BIOS :(
 

Collider

Senior member
Jan 20, 2008
514
4
81
Just tried to update BIOS to latest version from SuperMicro, but unfortunately there are no new settings. So still no way to Disable HT-Assist or Probe Filter.
 

LTC8K6

Lifer
Mar 10, 2004
28,523
1,573
126
What board is it?

It seems like HT Assist is only useful for 4 and 8 processor systems.
 

ShqTth

Junior Member
Apr 22, 2020
3
0
6
Under the processor it shows as the option "L3 cache feature". this is on my h8dgi-f. but on my other board that is single cpu (the one with pci slot), I cant seem to find it. Maybe the bios has to be modded? having 4MB missing sucks on a single cpu.
 

ShqTth

Junior Member
Apr 22, 2020
3
0
6
I forgot to mention. I ran into an issue a few times getting a bsod saying something about DPC Watchdog Violation. (I will update the error when I see it again). In the past it ended up corrupting my profile. Anyways my pc would freeze and eventually go into the BSOD. What fixed the problem was disabling HT assist/L3 cache feature. I was running 6378, now I am running 6386... I thought I mention this in case anyone. I had a few bios options disabled, and when I updated my cpu I re-enabled them, then the crashing started up again. I ruled out that this bios option caused the crashing. And I am not sure why. It may be related to running the cpus in power saver mode with core parking.
 

rvborgh

Member
Apr 16, 2014
190
80
101
it was possible to disable it on the previous gen multi cpu Istanbul setups (i ran a dual Opteron 8439SE a while back on a Tyan board). i currently run a SuperMicro H8QGi-F with 4 Opteron 61xx (which also uses HT-Assist/Probe Filter)... there is no way to disable it that i am aware of.
 

ASK THE COMMUNITY