How do you permanently kill the screensaver in Mint XFCE?

Red Squirrel

No Lifer
May 24, 2003
67,581
12,218
126
www.anyf.ca
I installed XFCE environment on what used to be Mint Cinnamon as I was having weird video related issues and I read that it might solve it, and it did.

But now no matter what I do, the screensaver keeps coming on. Even if I'm in the middle of watching a movie. Why are screensavers even still a thing? At very least it should not be on by default.

I also tried these commands, no go:

xset s 0 0
xset s off

I also shoved that in lot of scripts like startup etc. Everything I read tells me to do different things, so I'm just trying everything and no go.

This is also a serious issue on Raspberry Pis. It seems on some Linux systems it's easier than others.

Anything else I can try?
 

lxskllr

No Lifer
Nov 30, 2004
57,504
7,699
126
Uninstall it? Not sure what mint uses. Probably either gnome screensaver or xscreensaver. Either should have proper settings to adjust behavior. If it's simply powering down the monitor, it might be xfce power management. Adjust that in xfce settings.
 

whm1974

Diamond Member
Jul 24, 2016
9,460
1,570
96
Just turn off display power management in Xfce settings. that should fix the problem.
 

Red Squirrel

No Lifer
May 24, 2003
67,581
12,218
126
www.anyf.ca
I can't find any settings at all pertaining to screensaver, not sure what the package name is either. I tried apt-get remove xscreensaver and also gnome-screensaver but it says it's not installed. Part of the issue may be because it's not actually a XFCE version but rather a cinnamon with XFCE on top, so that might be causing issues as it's all mixed in with the other system.

I had the same issue with the newer raspberry PIs. There's like a bunch of different ways of doing it and they don't always work consistently between different units.
 

lxskllr

No Lifer
Nov 30, 2004
57,504
7,699
126
I like using synaptic for browsing packages. It's easy to filter results various ways. I'm sure there's a cli way to do everything synaptic does, but synaptic's easy. Anyway, install that, filter by installed, and search for "screensaver". Remove the stuff that looks relevant. Once those are gone, open your application menu, and look for "power manager". You can play with the settings in there.
 

Red Squirrel

No Lifer
May 24, 2003
67,581
12,218
126
www.anyf.ca
I found something called xfce4-power-manager-settings so I installed it. Did find an option for screensaver so I turned it all off, I'll see what happens.
 

Red Squirrel

No Lifer
May 24, 2003
67,581
12,218
126
www.anyf.ca
Well that didn't work. The settings don't stick after a reboot. There's got to be a universal way of single handedly completely killing the screensaver. I don't know why it's so hard depending on the distro. Raspbian has the same issue where it's very hard to get rid of it.
 

lxskllr

No Lifer
Nov 30, 2004
57,504
7,699
126
It can't be universal cause every distro is a collection of packages, and that collection will vary. Even in a single distro, the user can install what they want, so it can deviate from vanilla. Do a search for "screensaver" in your package manager, filter by installed, then remove it. You should be left with xfce's power manager, and that should be easy to figure out.
 

Red Squirrel

No Lifer
May 24, 2003
67,581
12,218
126
www.anyf.ca
I found cinnamon-screensaver but it says it wants to remove cinnamon itself too if I check to remove. Is that safe to do? I'm running xfce now, but since this is the cinnamon version of Mint I wonder if there's still stuff that relies on cinnamon to work properly.

Can I just delete the cinnamon-screensaver binary itself? Or will that cause issues?
 
  • Like
Reactions: UsandThem

lxskllr

No Lifer
Nov 30, 2004
57,504
7,699
126
I wouldn't remove anything outside the package manager. It can be done, but could cause problems that are hard to track down going forward. Removing cinnamon should be fine, but you could find some programs you like got removed with it. As long as they aren't inherent to cinnamon, you should be able to re add them without bringing in the whole meta package.

If this machine is critical, it wouldn't be a bad idea to image it before you start removing stuff. That's cheap insurance, and makes it easy to get back to where you are now. Otherwise, just pay attention to what you're removing, and you should be fine. If it doesn't look right, stop and consider what you're doing before proceeding.
 

Red Squirrel

No Lifer
May 24, 2003
67,581
12,218
126
www.anyf.ca
Still no go. I thought I had sorted it out but whatever I did didn't take effect after a reboot. Stupid screensaver still shows up. Why is it so hard to turn off? I had a similar struggle with the distro on the Raspberry PI. There's like 20 different ways of doing it and none of them seem to work permanently.
 

Red Squirrel

No Lifer
May 24, 2003
67,581
12,218
126
www.anyf.ca
Tried that, no go. I don't think it takes effect after a reboot, and putting it in startup script does not work, since I think it specifically needs to be run within the GUI environment.

I found something else, and it's to install xfce4-power-manager-settings and then run it and then change the settings. But I could have sworn I did that last time too... don't think the settings stick after a reboot.
 

Red Squirrel

No Lifer
May 24, 2003
67,581
12,218
126
www.anyf.ca
Seems this never sticks after a reboot. xfce4-power-manager seems to fix it, but only for that one session. Is there a way to make that change permanent? Since it's a GUI app I'm really not sure how I'd go about scripting that. I don't know why they make this so hard. Had the same struggles with the Raspberry Pi. It seems some Linux distros really make it hard for nothing to do simple tasks. Screensavers were only valid in CRT and early plasma display days, why are they even on by default?
 

mxnerd

Diamond Member
Jul 6, 2007
6,799
1,101
126
In my Mint Xfce 18 & 19 VM.

Click start icon, select Settings. Pull down the menu on the right side or you probably won't see it.

Click Light Locker Settings,

Screensaver section
I opened Xfce Power Manager, In General tab, disable all buttons. And in Display tab, turn off Display power management.

Locking section
Disable light locker.

Running overnight and the screensaver was disabled and never ran.
 
Last edited:

Red Squirrel

No Lifer
May 24, 2003
67,581
12,218
126
www.anyf.ca
I did not find that specific tool but something similar in the systray, there's a power icon. The issue is that it never seems to stick after a reboot. There's an option for how long until screen saver comes on, for when it's on AC and on battery, they're both set to "never" but it still blanks out the screen. If I fiddle around with the settings then set it back it works though, it's like if something at startup is overriding it, and by going in the settings to apply it, it then overrides it back.

One issue with Linux is it seems there's way too much duplication of work doing the same thing. How many freaking power mangers and screensaver mangers does it need? They all step on each other's toes, and who knows which one is actually "active". I uninstalled everything that has to do with screensaver but there still seems to be something at the system level regardless.

Might have to just look into a hardware solution. They started forcing screensavers at work now too, so even better reason to start developing something. Would be easy to do with a mouse and just hack it, but if I can come up with something that is like a USB stick, even better. Time to read up on HID protocol I guess. Wonder if I can bit bang that with an atmega. Once I can come up with the design I'll make a bunch of em. Don't have to mess around with trying to find a software solution after that whenever I install a new system.
 

mxnerd

Diamond Member
Jul 6, 2007
6,799
1,101
126
I tested the VMs on a PC, not a laptop, don't know if that makes any difference. But during my test, those VMs never ran the screensaver, even after reboot a few times.

Like what you said, Linux is very hard to deal with. Just too many distros, too many software packages , too many versions, and too many different ways to package them. It's a universe of complete chaos.
 
Last edited:

Red Squirrel

No Lifer
May 24, 2003
67,581
12,218
126
www.anyf.ca
Still early to tell but I THINK I may have figured it out. I timed to see how often it was doing it, and it was 10 minutes. So out of desperation I was just typing random package names to see if it exists.

light-locker-settings turned out to exist. That gave me the option that was previously not there under settings. I turned that off and after 10 minutes, no more screensaver. I even rebooted for good measure and it SEEMS to have sticked. I don't know if there's some other screen saver process that will overwrite that, but I'll have see while I'm watching a movie.
 
Nov 20, 2009
10,051
2,576
136
I would have just located the various screen saver files (whatever their extension in Linux), deleted them and created a fake screen saver file to set the screen saver to. When the timeout comes it'll attempt to execute the screen saver file but not work.
 

Red Squirrel

No Lifer
May 24, 2003
67,581
12,218
126
www.anyf.ca
Don't think there are screen saver files like in Windows. I tried to find all the executables related to screen saver and uninstall but it still was not doing it. I think it's built more deeply into X or the desktop manager or whatever, it's not just a single file.
 

kermur

Junior Member
Oct 5, 2022
1
1
6
I realize this thread is ancient, but maybe this will help someone:


I had a problem with the xfce screensaver freezing my VNC sessions. I did manage to find the settings to deactivate, but you can also just:

sudo apt remove xfce4-screensaver
 
  • Like
Reactions: igor_kavinski