Question How do I get FreeSync working?

SteveGrabowski

Diamond Member
Oct 20, 2014
5,150
3,976
136
Just installed a 6700 XT yesterday. Used DDU to remove my Nvidia drivers for the 1660 Super I had before I took it out of the system. For the life of me I can't figure out why FreeSync isn't working now with my 6700 XT. I have it turned on for my monitor. From the Adrenaline display settings I have FreeSync switched on, but it clearly isn't on since I'm seeing a ton of tearing in the FreeSync windmill demo with the test pattern turned on when running at 45/50/55 fps (FreeSync range is 40-60 Hz) and I uncheck VSync.

To get FreeSync working on my 1660 Super I would have to select GSync on and then force VSync on from the Nvidia Control Panel, while leaving it off in the games I was playing, but that doesn't seem to work here. Was running the Cyberpunk benchmark and not only does it go above 60 fps, it tears both below and above 60 fps.

Can someone ELI5 how to get FreeSync properly working on a 60 Hz panel with a FreeSync range of 40-60 Hz? Because it's not seeming to work right now for me through Adrenaline.

Using the newest stable drivers.
 

SteveGrabowski

Diamond Member
Oct 20, 2014
5,150
3,976
136
So wondering if this is the correct way to set this up for a 60 Hz FreeSync panel:

1. Turn on FreeSync in Adrenline
2. Turn on Radeon Chill
3. Set Min FPS to 57
4. Set Max FPS to 60

This is the only way that has gotten rid of tearing for me on Cyberpunk's ingame benchmark, and it sets a framerate cap of 57 fps. Which doesn't make sense from the settings, but oh well seems to work. And I see no tearing if I put the benchmark at settings to run 42-57 fps, which tells me the FreeSync range seems to mostly be working. If I set Min FPS to 58 I do get very minor tearing on the bottom of the screen and Min FPS up to 60 gives me very noticeable tearing at the bottom of the screen when the framerate gets that high.

So is this the correct way to setup FreeSync for a 60 Hz panel?

Wasn't working at all for me until I did another reboot, now seems to be working. Thank god, I really didn't want to return this card to get a 3060 Ti with gimpy 8GB VRAM instead for 1440p60 gaming.
 

Leeea

Platinum Member
Apr 3, 2020
2,738
4,124
106
Radeon driver -> gear thingy -> display settings -> Display options -> amd free sync enabled


Radeon chill is not necessary.
Frame rate limiters are not necessary.


Honestly, I never had that much of an issue with it. Not sure what to tell you.

I can see how it would be necessary on a 60 hz monitor.


You already enabled it on your monitor. That should be all you need to do, AMD gpu settings default with it on.
 
Last edited:
  • Like
Reactions: Shmee

Khanan

Member
Aug 27, 2017
185
71
111
Don’t use any limiters or vsync. Only activate FreeSync in the driver and on the monitor use the setting which has FreeSync on (like mine has) that should do it.

edit: seems my answer is a bit redundant
 

ASK THE COMMUNITY