How do I advertise loopback addresses?

Cooky

Golden Member
Apr 2, 2002
1,408
0
76
We have 2 3750's connected through routed interfaces on a fiber run.
I was going to run a test to make sure routing works.
After issuing the following into the 3750s, they can't establish neibor status:

ip routing
router eigrp 100
network 1.1.1.1 255.255.255.255
[network 2.2.2.2 255.255.255.255 on the other]

What am I missing? When I turn on debug eigrp, I keep getting messages saying that the 3750 is ignoring HELLO's from itself. How do I advertise the loopback interfaces?

thanks.
 

spidey07

No Lifer
Aug 4, 2000
65,469
5
76
You shouldn't have to do anything. all directly connected routes are advertised.

But you don't want the loopback in your network statements. That just tells the EIGRP process what interfaces to run on. you don't want to run it on a loopback.

alternatively to get rid of those messages make the loopback passive.

router eigrp 100
passive-interface loop0

 

Cooky

Golden Member
Apr 2, 2002
1,408
0
76
ok, I took off the network statements, and added passive-int lo0, but the two 3750s are still not forming neighbor, and I don't see the loopback interface in "show ip route"
 

spidey07

No Lifer
Aug 4, 2000
65,469
5
76
loopback interfaces won't form neighboors, those can only be made over a layer2 connection (like an SVI or WAN connection)

you should definately see a route for the loopback interface. just think of it as a virtual interface

for example, switch 1
int vlan 10
ip add 10.10.8.254 255.255.255.0
int loop 0
ip add 10.10.9.254 255.255.255.255

router eigrp 1
network 10.10.8.0 255.255.255.0
passive-int loop 0
no auto-summary

switch 2
int vlan 10
ip add 10.10.8.253 255.255.255.0
int loop 0
ip add 10.10.9.253 255.255.255.255

router eigrp 1
network 10.10.8.0 255.255.255.0
passive-int loop 0
no auto-summary

sh ip eigrp nei
sh ip eigrp int
sh ip eigrp topo
sh ip int loop0
 

Cooky

Golden Member
Apr 2, 2002
1,408
0
76
Thanks for the quick replies...
After adding the network that the physical/routed interfaces are in to EIGRP, the 3750's were able to form adjacency.

By the way, I had to add the loopbacks w/ network statement for them to be advertised...