Help with external display on laptop.

lakedude

Platinum Member
Mar 14, 2009
2,627
371
126
I've got an external keyboard/mouse and display hooked up to my laptop via a KVM. Getting the external display to work before it automatically shuts down has always been an issue with devices hooked up the the KVM. I quite often needed to switch the KVM to an always on ChromeCast dongle to wake the display up before switching to my phone or my old laptop. Opening and closing the lid on the old laptop usually did the trick.

Now comes a new laptop with an AMD RX 7700S GPU plus whatever iGPU comes with a 7735HS CPU. The screen isn't stable as it wonders what to do with the external monitor so changing any settings is a real pain. It takes me way too long to get the new laptop to put out a display to the external monitor. I'm sure the KVM and the short time the monitor gives before going to sleep isn't helping anything.

Ideas?
 

lakedude

Platinum Member
Mar 14, 2009
2,627
371
126
The monitor was set to never sleep so I changed the sleep setting to 30 minutes but it still sleeps within seconds of losing a signal.

A direct connection bypassing the KVM helps but I need the KVM.
 

mindless1

Diamond Member
Aug 11, 2001
8,207
1,505
126
I'd look around in the monitor's settings to see if there is something else besides the sleep timer setting you already saw.
 
  • Like
Reactions: lakedude

lakedude

Platinum Member
Mar 14, 2009
2,627
371
126
I'd look around in the monitor's settings to see if there is something else besides the sleep timer setting you already saw.
What the monitor called "sleep" was actually a timed shutoff that killed power completely.

I didn't see a setting for the monitor's 3-5 second hibernate/sleep but I got it sorted.

I set Windows to display#2 only. Works perfectly. If the external monitor isn't available the laptop's screen works as normal. When the external is hooked up it works, KVM and all.

I've lost the ability to mirror or extend but that is fine. I'm not interested in using the laptop's display at home anyway.