• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Help with ASUS RX550 2G (driver problems)

NiemandGekusst

Junior Member
Feb 3, 2020
1
0
6
Hey guys, first off let me leave some specs:
ASUS Prime A320M-K
AMD Ryzen 3 1300x
ASUS RX550-2G (https://www.asus.com/Graphics-Cards/RX550-2G/ )
LNZ SX-500-FC 500W
Kingston 8G DDR4 2400 MHz (Don't remember the exact model but it's one of those without any flashy logos/names and cooling things)
All components are 18 months old
Windows 10 Home version 1909
BIOS version/date: American Megatrends 3803 1/22/2018
SMBIOS version: 3.1
BIOS mode: UEFI


I want to start out by saying that ever since I've had this card, I've never been able to update the drivers, once, without having the problem I'm having currently, which I will explain in a bit. Also my GPU shows up as "Microsoft Basic Display Adapter" in device manager and also in GPU-Z, however, GPU-Z displays the correct specs (such as clock speed and whatnot) under the incorrect name and when I click "Lookup" it brings me to the correct page for my GPU (https://www.techpowerup.com/gpu-specs/radeon-rx-550.c2947 ), although it's not my exact model, but you can find it down there in the page.

This is what my screen looks like when I boot up with AMD drivers installed:





List of things I've tried:
updating the drivers with device manager, using the ones windows automatically finds
updating the drivers with Radeon-Software-Adrenalin-2020-20.1.3-MinimalSetup-200128_64bit
updating the drivers with Radeon-Software-Adrenalin-2020-20.1.4-MinimalSetup-200127_web
updating the drivers with Asus 18.10.16 WHQL
updating the drivers with the AMD Driver Auto-Detect Tool
updating the drivers with the drivers amd recommended to me when I selected my GPU on their website
Every option on the Windows 10 Recovery screen (restoration point - roll back - the rest), the one thing that makes my PC usable again is booting into safe mode, and I've tried rebooting out of safe mode with the faulty drivers installed but they still don't work.
Running AMD Driver Cleaning Utility before installing any of the aforementioned drivers
Installing drivers after running Display Driver Uninstaller
Booting into low res mode
formatting my PC and installing the drivers in a fresh windows 10

I remember that my card came with a CD which I think contained the GPU Tweak II program and maybe some drivers, but sadly I don't have the CD anymore.

I currently do not have access to another PC where I can install my GPU to try it and neither do I have another GPU I can use instead of the one I currently have.

Also, when I open up Photoshop CS6, it detects that there is something weird going on with my GPU. League runs at 2 FPS at max settings when it used to run at 120+ and some games like Dead by Daylight won't boot up because a message pops up telling me that DX11 is required to run it. My point is that other programs are aware of the driver change and it's not like I can just keep using my PC as if nothing happened.

It seems that no matter which version of the drivers I install, I always have the same problems:
During the driver installation process, the screen blacks out and never comes back, when I reboot my PC, after the ASUS logo screen where you can enter the bios, the screen displays a pixel glitch which covers up the entire screen.

I guess if I could just go back to the drivers the GPU comes loaded with, that would solve the problem, since I've been using those since July 2018 with no problems and great performance.

Oh also: After installing any drivers, when I reboot into safe mode my GPU shows as either Radeon 550 Series or Radeon RX550 depending which driver I install, even though the GPU name's is correct, League, for example, still runs extremely slow (20 FPS with the lowest settings). Also, my GPU never shows up on task manager even though it used to before all of this happened and it still shows us as Microsoft Basic Display Adapter when I run dxdiag.exe. And as I've previously said, if I were to reboot out of safe mode into "normal mode" I would still get the screen glitch, the only way to go into normal mode without any glitches is to roll back to drivers with device manager to "Microsoft Basic Display Adapter", however, that renders my GPU useless since it won't process anything.
 

CuriousMike

Diamond Member
Feb 22, 2001
3,021
504
136
Do you have a spare harddisk?
If so, install a fresh version of Windows on it. Install _nothing_ else.
Then install the drivers and see if the problem persists.

(The idea is to try separate hardware issue from software issue.)
 

Arkaign

Lifer
Oct 27, 2006
20,724
1,354
126
Sounds like you're sitting on a bum card. It happens.

As it stands, the 550 is pretty horrendous, getting completely dominated by older stuff like the RX460, 260X, 750Ti, etc.

IF you can return for full credit or refund, it would be beneficial for you to get any of the Nvidia 750/950/1050 or better, best drivers and extremely efficient. Alternatively, RX460/560 or better would be far better AMD options.

Barring that possibility, RMA is your other route. Unfortunately, the 1300X has no IGP, so you're stuck with perhaps nothing if you have no spare until the replacement would come, which can take quite some time depending on the company. EVGA is great about that, advance RMA can take under a week. Not sure how Asus GPU RMA goes.
 
  • Like
Reactions: VirtualLarry

Shmee

Memory and Storage, Graphics Cards
Super Moderator
Sep 13, 2008
5,417
1,033
126
I agree, looks like a hardware issue, the card is not stable. I would replace it or RMA it.
 
  • Like
Reactions: VirtualLarry

ASK THE COMMUNITY