How To Help ! Linux black screen

Markfw

CPU Moderator, VC&G Moderator, Elite Member
Super Moderator
May 16, 2002
17,092
535
136
#1
OK, its been a while. So I had a perfectly working setup, but I kept hearing the fans start and stop. So I did the below:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration

cd ~

gedit fancontrols

and add and then save (for 2 video cards)

nvidia-settings -a [gpu:0]/GPUFanControlState=1
nvidia-settings -a [fan:0]/GPUTargetFanSpeed=85
nvidia-settings -a [gpu:1]/GPUFanControlState=1
nvidia-settings -a [fan:1]/GPUTargetFanSpeed=75

============================================

Now I have a black screen (with a graphic mouse cursor) when I boot ! But my remote F@H says its running, and I assume BOINC is still running. Is there any easy way to fix this ?
 

Ken g6

Programming Moderator, Elite Member
Moderator
Dec 11, 1999
14,240
206
55
#2
Try ctrl-alt-f2 to get a command line log in. Try 'watch sensors' to see if your CPU is overheating.
 

Markfw

CPU Moderator, VC&G Moderator, Elite Member
Super Moderator
May 16, 2002
17,092
535
136
#3
I did that.68c just like I thought. Where is the file xconfig that I created ? I think maybe if I delete what I created it will fix it.

And it can't be the overheating as its worked perfectly for weeks, until I did the above, I created 2 files I think. I want the fancntrols, I think I want to undo the xconfig and empty config, etc.
 
Last edited:

Ken g6

Programming Moderator, Elite Member
Moderator
Dec 11, 1999
14,240
206
55
#4
It should be at /etc/X11/xorg.conf. There might be backup files in the same directory.
 

Markfw

CPU Moderator, VC&G Moderator, Elite Member
Super Moderator
May 16, 2002
17,092
535
136
#5
OK< how do I rename files as "root" I get permission denied.
 

Markfw

CPU Moderator, VC&G Moderator, Elite Member
Super Moderator
May 16, 2002
17,092
535
136
#6
ok I guessed at add sudo at the beginning of the line and it worked, and by that I mean, I renamed the file-rebooted, and the screen is back. Not sure if the fancontrols worked or not yet.
 
Last edited:

biodoc

Diamond Member
Dec 29, 2005
5,026
88
126
#7
OK, its been a while. So I had a perfectly working setup, but I kept hearing the fans start and stop. So I did the below:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration

cd ~

gedit fancontrols

and add and then save (for 2 video cards)

nvidia-settings -a [gpu:0]/GPUFanControlState=1
nvidia-settings -a [fan:0]/GPUTargetFanSpeed=85
nvidia-settings -a [gpu:1]/GPUFanControlState=1
nvidia-settings -a [fan:1]/GPUTargetFanSpeed=75

============================================

Now I have a black screen (with a graphic mouse cursor) when I boot ! But my remote F@H says its running, and I assume BOINC is still running. Is there any easy way to fix this ?
There's a couple of steps missing according to the Brony guide.

1) make the file, fancontrols, executable:
chmod +x fancontrols

2) Add the fancontrols executable to your startup applications.
go to start menu, then preferences or administration and look for "startup applications'. Once open choose add, then give it a name and 'browse' for your file fancontrols. Then choose save. You'll need to reboot.

To check fan speed and temps, run nivida-settings or nvidia-smi
 

lane42

Diamond Member
Sep 3, 2000
5,062
36
106
#8
Is this for gpu fan control speed.
I run ubuntu 16.04 and use nvidia xserver with a nice gui fan control sliders.
 
Aug 2, 2003
3,132
261
136
#9
I am probably wrong, lane42, but I think xserver doesn't know how to deal with EVGA's independent fan control system. But the cool-bits flag is able to over-ride both/all fans.
 

lane42

Diamond Member
Sep 3, 2000
5,062
36
106
#10
If you have xserver installed, I just copy and paste this,
sudo nvidia-xconfig --thermal-configuration-check --cool-bits=28 --enable-all-gpus
into terminal, enter, password, enter, then reboot computer.
Now nvidia xserver has fan control
 

biodoc

Diamond Member
Dec 29, 2005
5,026
88
126
#11
If you have xserver installed, I just copy and paste this,
sudo nvidia-xconfig --thermal-configuration-check --cool-bits=28 --enable-all-gpus
into terminal, enter, password, enter, then reboot computer.
Now nvidia xserver has fan control
This works for you and me but MarkFW has a lot of machines. I think he wants to set the gpus at a certain fan speed automatically at each boot. I use nvidia-settings (gui) to set the fan speeds but I have to reset them after each boot.
 

Rudy Toody

Diamond Member
Sep 30, 2006
3,997
47
106
#12
This works for you and me but MarkFW has a lot of machines. I think he wants to set the gpus at a certain fan speed automatically at each boot. I use nvidia-settings (gui) to set the fan speeds but I have to reset them after each boot.
This may be a bit off-the-wall, but could we use something like, "Hey, Alexa! Set my fan speeds to default on PC Waldo."
 

lane42

Diamond Member
Sep 3, 2000
5,062
36
106
#13
Now that would be cool Rudy :)

I just do it this way because it's so easy to control fan speeds. it really only takes
seconds to adjust each gpu fan speed. I run seti. When I do F@H or Prime grid,
my gpu's run 10c warmer. just open xserver slider the slider over, done. it's
even fun to play with.
 

Rudy Toody

Diamond Member
Sep 30, 2006
3,997
47
106
#14
Now that would be cool Rudy :)

I just do it this way because it's so easy to control fan speeds. it really only takes
seconds to adjust each gpu fan speed. I run seti. When I do F@H or Prime grid,
my gpu's run 10c warmer. just open xserver slider the slider over, done. it's
even fun to play with.
I posted more detail in our stealth thread.
 

ericlp

Diamond Member
Dec 24, 2000
5,983
42
106
#15
I always use... chmod -R 777/target folder

just don't do it to the entire drive (like root) or you could break a few things..


if in doubt. That gives permissions to Anyone... as long as your not a network administrator in a workplace, that command should be fine.
 
Last edited:

StefanR5R

Platinum Member
Dec 10, 2016
2,258
343
106
#16
I prefer the [ugoa][+-=][rwxXst] syntax to chmod.
And I avoid giving more permissions than necessary (especially to "others").
 

ericlp

Diamond Member
Dec 24, 2000
5,983
42
106
#17
I islate most of my linux machines so.. there are no "others" lol. There is a way to make yourself the root and get rid of all others, but you need to really start off with this before installing other programs. It's probably the way I am going to go, when I install linux for my next build. I hate the sudo command. If someone telnetted into your system...They could just use the SUDO command all day long...so I don't see the point in having it.
 

StefanR5R

Platinum Member
Dec 10, 2016
2,258
343
106
#18
Remote attackers usually break in by exploiting a buggy system service, or via a trojan. (And then they attempt to exploit privilege escalation bugs, because services or trojans generally run unprivileged.) IOW break-ins mostly happen without knowledge of username/password combos.

On my main home PC, I have a terminal open most of the time in which I am logged in as root. Thus I rarely use sudo on that machine.

On my boinc crunchers, the main user is member of group "boinc" for more convenient access to the boinc files. Or boinc is even running from that main user account.
 

lane42

Diamond Member
Sep 3, 2000
5,062
36
106
#19
Linux noob here, Don't you need a password to run a SUDO command ?
 

StefanR5R

Platinum Member
Dec 10, 2016
2,258
343
106
#20
Don't you need a password to run a SUDO command ?
Short answer: Yes, generally.

Long answer: This can be configured in different ways. By default, many Linux distributions configure sudo for the initial main user such that
  • the password of the invoking user must be entered when sudo is invoked (but it could also be configured to run without password, or with password of a certain other user),
  • the password is cached for a while, e.g. 5 minutes, such that the user isn't bothered with more password prompts when he issues a few sudo commands in a row (but it could also be configured not to cache the password, or more precisely, the authentication),
  • this password cache is only granted within the same login session/ pseudo terminal, such that the same user needs to enter the password again if logged in via a different pseudo terminal (but sudo could also be configured to have a single authentication cache for all pseudo terminals),
  • any user, e.g. root or boinc or fahclient or mail or..., is acceptable as target user (but it could also be set to accept only one or some specific target users),
  • any command is acceptable for execution with target user identity (but it could also be set to allow only specific commands).
 

Kiska

Senior member
Apr 4, 2012
629
8
116
#21
Don't you need a password to run a SUDO command ?
You can do:
Code:
james ALL=(ALL) NOPASSWD:ALL
This will cause all sudo commands to be executed without your user password. In this case the user is james
 

lane42

Diamond Member
Sep 3, 2000
5,062
36
106
#22
@ Markfw, sorry for stepping on your thread.
Hope you got your fan control sorted out :)
 

Similar threads



ASK THE COMMUNITY

TRENDING THREADS