Help!!! Detonator drivers (June 11) won't install

Kosheen

Junior Member
Jan 17, 2001
12
0
0
I have a question/problem regarding updating Nvidia drivers:

I recently performed a fresh install of Windows 2000 on my system. It correctly detected my Nvidia RIVA TNT (driver dates from 1999). Then I downloaded the latest drivers from Nvidia (June 11) and ran the installer program. Apart from unpacking lots of stuff it flew through the process like it was nothing. But after rebooting I'm still stuck with my standard driver dating from 1999... no Nvidia tools, nothing, no glide...

I uninstalled then my graphics card in Win2k, rebooted, repeated the installation of the Nvidia drivers ("just click on the 29.42_winxp executable", yeah right!), rebooted again and guess what, that damn irritating standard W2k driver from 1999 was back and keeps coming back

Can anyone tell me wether I'm doing something seriously wrong or so? I'm logged in as admin so that can't be it and the system now has SP2 applied with IE6 and DX8.1, still no go... The frustrating thing is that on my previous installation on the same machine the previous drivers worked like a charm :(.

All help is appreciated!
 

Kosheen

Junior Member
Jan 17, 2001
12
0
0
Well I'll be damned, I figured it out! Read this:

I went to www.3dchipset.com to get their drivers because they come in Zip files. When trying to add the drivers manually (you know using the "Have Disk" option) it appears that the latest Nvidia drivers don't support the good old Riva TNT anymore, but support starts at Riva TNT2 from now on... Reverting back to 21.83 solved the problem but I think Nvidia could have at least included a readme on which cards are supported and which aren't anymore. Anyway, it works from now on and I have added to my troubleshooting experience.

P.S.: I think this is their gentle way of pushing me towards a GeForce 4 ;) but give it two months and I'll have the necessary $ to get one :D.
 

ASK THE COMMUNITY