Question Hard drives only turn off when I stop using computer

Feb 2, 2007
40
0
66
#1
I use an SSD for Windows and apps but still have to use a traditional hard-drive for storage. 75% of the time I do not need to access that drive and I would love that it would start only when I access it from file explorer as my computer would be dead silent when they are off.

I turned on "Turn off hard drives after 30 minutes" but they only turn off after my display has turned off from inactivity, or when I lock my computer. They also turn on immediately after I move my mouse to wake up the screen.

In Win7 and previous windows, the hard-drives turned off after x minutes when I did not read anything from them, and turned on when I tried to browse them in the File Explorer. Has this logic changed or is there some trick to get it to work like that?

Thanks!
 

StinkyPinky

Diamond Member
Jul 6, 2002
6,371
51
126
#2
I'm guessing you have some program that is writing to the hard drive when the PC is on.
 
Feb 2, 2007
40
0
66
#3
There should be nothing. It's three days old win10 install and I just added the drives which have no apps or similar. I disabled indexing from windows also.
 

corkyg

Elite Member | Peripherals
Super Moderator
Mar 4, 2000
27,214
42
106
#4
A foolproof way is to put that drive in a mobile rack, then you can physically turn it off and on with ease. Alternatively put it in an external drive case that can be turned off and on.
 

mxnerd

Diamond Member
Jul 6, 2007
4,242
115
126
#5
Change your current power plan in Control Panels, Power Options, Advanced Settings

 

balloonshark

Diamond Member
Jun 5, 2008
3,375
119
106
#6
I had a Windows 8.1 install that I set to turn off my data drive after x amount of minutes. I kept hearing my data drive spin up several times a day without me doing anything. I checked task manager and found a couple of different Windows processes using a disk. Then I checked my firewall and the processes were sending data to Singapore. All this started after the Windows telemetry spyware updates.

Not saying this is your problem but it's worth looking into.
 
Feb 2, 2007
40
0
66
#7
A foolproof way is to put that drive in a mobile rack, then you can physically turn it off and on with ease. Alternatively put it in an external drive case that can be turned off and on.
I would prefer to keep them in the computer and get this to work. Otherwise it's just too much effort.

Change your current power plan in Control Panels, Power Options, Advanced Settings
That's where I changed the option. As this is a desktop, I don't have those on battery / plugged in options.
 

C1

Platinum Member
Feb 21, 2008
2,182
11
91
#8
Based on some net searching, this issue seems to turn up (when it does) with those who have "upgraded" to Windows 10 from typically Windows 7.

Some successful solutions reported include ensuring that the affected drive is set to AHCI in the BIOS (versus IDE) as well as use of the HDPARAM tool (for Windows) to disable the hard disk's advanced power management (APM level setting).
 
Feb 2, 2007
40
0
66
#9
Based on some net searching, this issue seems to turn up (when it does) with those who have "upgraded" to Windows 10 from typically Windows 7.

Some successful solutions reported include ensuring that the affected drive is set to AHCI in the BIOS (versus IDE) as well as use of the HDPARAM tool (for Windows) to disable the hard disk's advanced power management (APM level setting).
Thanks for the reply! I did a clean install from usb-stick straight to W10 64x.

I checked that all the drives are in AHCI mode in bios. I guess I could give that HDPARAM tool a try.
 
Feb 2, 2007
40
0
66
#10
Okay this might be all my stupidity, but I did not realize that I had to switch from "Balanced" to "High performance" power plan, even when I had the "Turn off the hard disks after.." enabled on the Balanced mode!

Now with the High Performance enabled (with the exact same settings as in balanced), the hard-drives seem to turn off while using the computer and do not wake up until I access the drives! Yey! Thank you everyone and sorry if this was something I should have known!
 

C1

Platinum Member
Feb 21, 2008
2,182
11
91
#11
More than ever, this sounds like a "bug" in Windows10.

The fact that there is an option for specifying the period for HDD "turn off" plus the concept or notion of "balanced power plan" imply that Microsoft has missed something in the Win 10 OS version.

Why would a balanced power plan not spin down an unaccessed HDD to save power?

The description of the "high performance power plan" predominantly involves running the CPU at full power. Having to be locked in to the "high performance" option in order to attain spin down of an unaccessed HDD doesnt make sense, at least to me.

In addition, this isnt the way things worked in earlier OS versions, so all-in-all this is a "bug" to me.

Besides, there are enough similar complaints seen on the networks regarding this matter from users who have upgraded their systems to the Windows 10.
 

Similar threads



ASK THE COMMUNITY

TRENDING THREADS