Frustrating problem with Win10 SMB/CIFS networking and QNAP NAS

VirtualLarry

No Lifer
Aug 25, 2001
56,009
9,878
126
I've got a few QNAP NAS units, a TS-212, a TS-431, and a TS-451.

I store Linux ISOs on two of them.

I went to access one of them, and it prompted for a Username/Password. Well, I fudged the text entry, and accidentally hit ENTER after typing part of a username. So it logged on with that username, gave me the list of shares, and then when I double-click the share that I want, it wants a username / password.

No problem, right, just enter the correct username / password for that share, right? WRONG. When I do that, it gives me an error that I can't be logged in with two usernames at once.

So, how do you "forget" a username for a server or share? There doesn't appear to be a way.

And I opened a Admin Command Prompt, and used a Net Use command, to map the share, but when I finally got the share mapped, it won't show up in Explorer! (I had this happen before, with a different version of Windows, in the very distant past, like maybe XP. I think I had to Task-Kill the root Explorer.exe shell. I already tried closing the Explorer window and re-opening it.)

This is nuts. You mean, I have to re-boot my workstation, in order to get another shot at getting my NAS credentials correct?

Edit: Yessiry! You have to "log out" of your workstation session, in order to "forget" cached credentials.

This is a MAJOR oversight by Microsoft. Not the least because of Network-based Ransomware, which can then access every share you've authenticated with during your login session, with no way to "forget" the login credentials.
 
Last edited:

VirtualLarry

No Lifer
Aug 25, 2001
56,009
9,878
126
I didn't map the share. Just double-clicking on the Server name under the Computer section under Network in Explorer, and then accidentally typing something and hitting ENTER is enough to bodge up the works, so bad that you have to Log Off and back On again to fix it. Meanwhile, all the programs you were using have to be re-opened, etc.
 

XavierMace

Diamond Member
Apr 20, 2013
4,307
450
126
You specifically stated:

And I opened a Admin Command Prompt, and used a Net Use command, to map the share, but when I finally got the share mapped, it won't show up in Explorer!

But now you say you didn't map it. In either case... Based on the way you describe the issue, this isn't a Microsoft CIFS/SMB issue, it's a QNAP CIFS/SMB issue. If you entered invalid credentials, it shouldn't have allowed you to connect at all. But it let you connect. Then it doubled down on that dumbness by telling you that you can't login twice.

This is also where having a directory service running comes in handy. :)
 

VirtualLarry

No Lifer
Aug 25, 2001
56,009
9,878
126
Then it doubled down on that dumbness by telling you that you can't login twice.

That's a Microsoft error, AFAIK.

And I did map the share, on the command-prompt, AFTER I had the issue, with not being able to log in via Explorer (due to it accepting an invalid username, with no password). But due to whatever, the command-prompt mapping, didn't extend back out to the Explorer window.

And AFAIK, with SMB, there's an authentication for the Server, and an authentication for the Share. Most of the time, they are the same. But the QNAP was apparently configured with "open" Server authentication, but required Share authentication.

Just like WAPs, I guess. They are generally set for "open" association, but WPA2 authentication. IOW, you can associate with a "Secure" WAP, all you want, you just can't get an IP or connect through to the network without authentication.
 
Feb 25, 2011
16,719
1,423
126
net use delete * and then remap the drive TO A DRIVE LETTER with the right credentials. Otherwise, yeah, it won't show up in Explorer (although you can still type the UNC path in a window to navigate there. It will use the existing cached credentials if it's already connected to the server.)

Windows is generally a dick about credentials.
 

Dahak

Diamond Member
Mar 2, 2000
3,752
25
91
Look in control panel - > Credential Manager.
That is where it would store the saved password when you get the Explorer password box
 

[DHT]Osiris

Lifer
Dec 15, 2015
13,135
10,960
146
Explorer does caching as well, beyond the credential manager. And yes it's retarded about how it functions. Welcome to Windows networking, where nothing makes sense!

In theory you could probably force crash explorer.exe and fire up another instance from task manager, but it's prolly faster/more stable to just log off/back on.
 

VirtualLarry

No Lifer
Aug 25, 2001
56,009
9,878
126
Ok, more weirdness. I woke up my Win10 PC, and did some stuff on it, then I wanted to save some ISOs to my NAS units. Opened Explorer, clicked on Network. Hmm.

WHERE ARE MY NAS UNITS???

Under "Computer", all of my desktop PCs show up (most running Win7), and my networked Brother printer, but my three QNAP NAS units, and my Lenovo NAS, are no-where to be found!

I hit F5 repeatedly to refresh the screen, nope. Network and Sharing center, says my network is "private".

WTF is going on?

Now, this evening, I DID change my FIOS connection speed. I don't know if they remotely rebooted my router or not.

I actually have a dual-router config, the FIOS router handles the connections in from the internet, and then my secondary LAN router handles my LAN and wifi needs. Thing is, even if my IP address changed on the FIOS router, that shouldn't really affect my LAN router... except, I just realized, I have my LAN router set to use 192.168.1.1 as my DNS server, which is the FIOS router. So, maybe the DNS has gone wacky. Although, I would think that the DNS registrations and lookups for 192.168.2.1 (my LAN) wouldn't propagate upstream through the WAN connection, surely.

Edit: Oh, the NAS units DO show up under "Network" in Explorer, under "Media Devices" and under "Storage", but not under "Computer", which makes browsing servers and shares, kind of impossible.

If I double-click the NAS icons under Storage, it opens a web page to the admin login page for each NAS unit.

Edit: I can still access the NAS units, and browse the list of shares, by using the \\SERVERNAME in the URL bar in Explorer.

Is this some new (unfortunate) change, in the way Explorer.exe functions, due to a recent Win10 patch?

Edit: I rebooted both my FIOS router and my LAN router.

One of my NAS units disappeared under the Storage section, and my Brother printer showed up multiple times, under "Multifunction Devices", "Printers", and "Scanners".

Edit: The NAS unit that went missing under the Storage section, just re-appeared.

Still no NAS units showing up under Computer.

Could this have something to do with LANMANv2 hashes for passwords, and the NAS units support that for backwards compatibility, but my Windows 7 and 10 machines have deprecated that, and Windows 10 due to a patch now filters out those devices that allow the older hashes, for security reasons???

Edit: It does appear to be something screwy with my Win10 machine. I went on one of my Win8.1 7" tablets last night, and it could see all my PCs, and my NAS units, all under the Network / Computer section in Explorer.
 
Last edited:
Feb 25, 2011
16,719
1,423
126
Network shares don't show up under "my computer" (or whatever they're calling it now) unless you map or mount the server folder. (Not necessarily to a drive letter, but I recommend mounting to a drive letter for backwards compatibility purposes.)

Edit: auto discovery relies of DNS resolution at least sort of working, and mDNS (Apple calls it Bonjour) to be running on all the systems involved. some routers seem to filter mDNS autodiscovery traffic.
 

VirtualLarry

No Lifer
Aug 25, 2001
56,009
9,878
126
Network shares don't show up under "my computer" (or whatever they're calling it now) unless you map or mount the server folder. (Not necessarily to a drive letter, but I recommend mounting to a drive letter for backwards compatibility purposes.)

I think I understand what you're saying. But I'm not talking about "My Computer". I'm talking about opening Explorer.exe, and clicking on "Network". Which, normally shows all devices on the LAN that have SMB sharing enabled, under a section called "Computers" at the top. That's where my PCs and my NAS units all used to show up. (And still do, on my Win8.1 tablet. I haven't sat down and checked my Win7 boxes.)

My NAS units no longer show up there at all, on my Win10 box. Only the actual PCs do.

Edit: My J1900 Win7 64-bit SP1 box, sees all of my devices (PCs and NAS units) under Explorer.exe,
"Network", and then under the "Computer" section. (Not Explorer.exe, "My Computer".)
 
Last edited:

VirtualLarry

No Lifer
Aug 25, 2001
56,009
9,878
126
Solved? I had to reboot, after trying out some new overclocking settings, and I just looked now in Explorer.exe, and all of my NAS units are back.

I don't quite understand it.
 

VirtualLarry

No Lifer
Aug 25, 2001
56,009
9,878
126
It's not like the devices weren't seen at all, though. They showed up under the "Media" and "Storage" categories, just not "Computer".
 

VirtualLarry

No Lifer
Aug 25, 2001
56,009
9,878
126
But in order to browse SMB Servers / Shares, they show up under "Computer". The icons that show up under "Media" open Media Player when you click on them, and the ones that show up under "Storage", just open up a web browser to the admin page on the NAS.
 

[DHT]Osiris

Lifer
Dec 15, 2015
13,135
10,960
146
Windows (and others) network discovery is pretty much garbage. I've always found it very unreliable. Map a network drive to keep it permanent or make a shortcut on your desktop.