• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Freesync woes...

SketchMaster

Diamond Member
Feb 23, 2005
3,098
149
116
After sitting on an old LCD and HD7850 for too long, I finally upgraded to 2x 480s and an LG 29UM68-P monitor for a sweet gaming experience.

The only issue is, I can't for the life of me get freesync to work on anything but the tech demo...

Troubleshooting steps:
  • Made sure I hade the correct cable (display port)
  • insured I'm running the latest drivers
  • Made sure Freesync was enabled in AMD control panel
  • Enabled Freesync on monitor
  • Set Monitor refresh rate to 75hz in Windows display settings
The windmill demo runs great, but I power up any other game and get tearing everywhere. FPS counter is going way above 75FPS in BF4 (DX11), DOOM, and every other game that I play. I've tried every damn setting I can find but nothing works.

Any ideas?

Thanks.
 
Last edited:

SketchMaster

Diamond Member
Feb 23, 2005
3,098
149
116
That seemed to help. I still feel like there is a bit of tearing, but nowhere near as much.

It seems silly to me that I have to limit the card to get freesync to work correctly. I would have assumed the drivers where smart enough to do that on their own. Maybe I had my expectations set to high for freesync?
 

Eymar

Golden Member
Aug 30, 2001
1,645
14
81
It's the same with G-Sync, you'll get tearing if FPS above monitor refresh rate as Gsync is no longer active. Either run frame limiter (limit should be below refresh so ex. 70FPS for 75hz as freesync will turn off if FPS is too close to max refresh rate) or Vsync on (FS will always be on up to max refresh) when videocard can run above refresh. Another problem you have is crossfire which works best when both cards are under full load (ie. FPS can't hit monitor's max refresh) as frame pacing is pretty smooth. I will disable crossfire on a per game basis because game will look smoother running FS + single card at 60-75 FPS then FS + XF at 75 FPS because of stutters caused by XF frame times.
 

Bacon1

Diamond Member
Feb 14, 2016
3,430
1,008
91
That seemed to help. I still feel like there is a bit of tearing, but nowhere near as much.

It seems silly to me that I have to limit the card to get freesync to work correctly. I would have assumed the drivers where smart enough to do that on their own. Maybe I had my expectations set to high for freesync?
If you are above the refresh range freesync (and gsync) won't work. So you can limit it with vsync or frame limiter
 
  • Like
Reactions: Headfoot

SketchMaster

Diamond Member
Feb 23, 2005
3,098
149
116
It's the same with G-Sync, you'll get tearing if FPS above monitor refresh rate as Gsync is no longer active. Either run frame limiter (limit should be below refresh so ex. 70FPS for 75hz as freesync will turn off if FPS is too close to max refresh rate) or Vsync on (FS will always be on up to max refresh) when videocard can run above refresh. Another problem you have is crossfire which works best when both cards are under full load (ie. FPS can't hit monitor's max refresh) as frame pacing is pretty smooth. I will disable crossfire on a per game basis because game will look smoother running FS + single card at 60-75 FPS then FS + XF at 75 FPS because of stutters caused by XF frame times.
Good to know. I was running my games at 74 FPS, I'll try running them at 70FPS and see if that helps. BF4 is the worst, bottom of the screen can turn into a big blur at times with all the tearing.

I was tempted to sell the 480s, return the monitor, then buy a GTX 1070 to pair with a 144Hz screen. Upon further research, it's not much better for the money. You'll still notice tearing WO G-Sync/FreeSync and 144hz monitors are not cheap. :eek:

Edit: Nope... Still getting tearing at 70FPS. :(
 
Last edited:

Erenhardt

Diamond Member
Dec 1, 2012
3,251
104
101
Good to know. I was running my games at 74 FPS, I'll try running them at 70FPS and see if that helps. BF4 is the worst, bottom of the screen can turn into a big blur at times with all the tearing.

I was tempted to sell the 480s, return the monitor, then buy a GTX 1070 to pair with a 144Hz screen. Upon further research, it's not much better for the money. You'll still notice tearing WO G-Sync/FreeSync and 144hz monitors are not cheap. :eek:

Edit: Nope... Still getting tearing at 70FPS. :(
Maybe you have a split second frame drops to very low value.
Tune your freesync range. I have LG 29UM67P which is very much like your and I've overclocked freesync to 30-75Hz. That gives you Low Framerate Comansation asweel as wide range of freesync perf.
Here is a good table how to set up your freesync monitor when it comes to V-sync and tearing:
https://www.amd.com/Documents/freesync-lfc.pdf

This is the reddit thread about overclocking free sync:
https://www.reddit.com/r/Amd/comments/3u9h3r/lg_29um67p_freesync_range_increased_to_3075_hz/

Here is a download for overclocked freesync driver:
https://www.dropbox.com/s/x1nyaaxovorzdt6/LG29UM67P_freesync30.inf?dl=0

All you have to do is to go into you monitor properties > driver > update driver > browse my computer > select tuned freesync driver > install > restart, voilla!
Should look like this:

No tears ;) enjoy
 

Erenhardt

Diamond Member
Dec 1, 2012
3,251
104
101
Also. In my LG monitor menu Gaming mode and freesync are two different settings.
Game Mode is enabled in the Picture menu settings
FreeSync is enabled in General Options menu.

You can have Game Mode Disabled and FreeSync anabled and vice versa. One is not tied to the other
 

SketchMaster

Diamond Member
Feb 23, 2005
3,098
149
116
Thanks for all the help, guys. Sadly, still no love.

FreeSync is turned on in the monitor settings, I called it "game mode" for some reason. I'm running all games in fullscreen. I used MSI afterburner w/100ms polling to check my framerate, holding steady at 70FPS in the BF4 test range. I even tried disabling CF to see if that was causing the issue.

Yes, Feesync does work in the windmill demo, which is why I'm so boggled as to why it won't work in games.
 
Last edited:

Erenhardt

Diamond Member
Dec 1, 2012
3,251
104
101
Very strange. Run GPUs at stock. Maybe you are getting artifacts. Can you record the tearing with external camera?
 

SketchMaster

Diamond Member
Feb 23, 2005
3,098
149
116
Very strange. Run GPUs at stock. Maybe you are getting artifacts. Can you record the tearing with external camera?
As requested.

Sorry if I sound a little grumpy, I've been trying to fix this for days and it's bothersome to have spent all this money just to be disappointed. :(

Not overclocking. The only tweaks I've made are to the fans to let them spin up to 5k (I game with headphones so blowers don't bug me). I'm actually started wondering if it's the monitor so I put in a return for it to Amazon, may give a 144hz monitor a try.
 
Last edited:

ThatBuzzkiller

Senior member
Nov 14, 2014
850
81
91
Now I'm confused, are you saying that I need Vsync on to get Freesync to work? That thread seems to say that Freesync should work as long as the card is running between 45-75FPS, V-Sync will only kick in when the card is producing more/less FPS than that range.
Well following from that thread, "What you should do is turn vsync on all the time. When both vsync and FreeSync are enabled, you automatically get FreeSync when the frame rate is within range, and vsync otherwise." so freesync only seems to work if you enable forced whole screen refresh with vsync ...

As they said, turn on vsync while freesync will work in the background to adjust the monitor's refresh rate latency ...
 

Erenhardt

Diamond Member
Dec 1, 2012
3,251
104
101
While the freesync demo runs at 60fps, battlefield was running at 70fps. That is the single difference that could be the cause of tearing.
In amd drivers > display Mouse-over enable freesync button. It should give you a pop-up about what range it is working. Maybe your monitor driver is bugged and your freesync works in lower range than it should?
 

SketchMaster

Diamond Member
Feb 23, 2005
3,098
149
116
I checked that also, max is 75Hz so I should be well within that.

Turning on V-Sync does get rid of tearing, but then it feels like straight v-sync and not free sync is running; input is laggy and some games will only run at 60FPS with VS on.
 

SketchMaster

Diamond Member
Feb 23, 2005
3,098
149
116
Going to try swapping out parts, I have a new monitor coming in tomorrow. I decided to give 144hz a try since I was returning the monitor anyway. I'll try running each card solo to see if it's one of them. If I still am having trouble I'll give my computer a fresh install as a last ditch effort to get this all working.

If after all that I still can't get Freesync to work I'll give up and just live with tearing.
 
Last edited:

Erenhardt

Diamond Member
Dec 1, 2012
3,251
104
101
Try updating monitor drivers ((not radeon display drivers). Are you using win10?
I'll have second rx480 in a couple of days, so I will test how it works with xfire. We have almost the same displays (mine is M67P).
 
  • Like
Reactions: SketchMaster

Erenhardt

Diamond Member
Dec 1, 2012
3,251
104
101
Also, Try g-gsync pendulum demo. It allows you to set fps range. Try to find a point at which the tearing begins. I bet this is something with monitor driver freesync range.
 

tential

Diamond Member
May 13, 2008
7,363
640
121
Can you please test 50/fps hz instead of the 70 fps? Are you also getting tearing/issues below 60 fps?
 

SketchMaster

Diamond Member
Feb 23, 2005
3,098
149
116
I updated the Monitor driver, even installed the on-screen utility.

Still get tearing in the Nvidia demo and BF4 regardless of FPS range.
 
Thread starter Similar threads Forum Replies Date
E AMD 5

ASK THE COMMUNITY