Question Flashing firmware to iPhone 4S A1387


Junior Member
Mar 27, 2023
When I found an iPhone 4S A1387 in garbage can, it was not usable and activation had to be done through WiFi internet, but it was not possible because the manufacturer's servers were offline and it was not possible through iTunes either. I tried various programs to re-install the software on the phone, and I downloaded iPhone4,1_9.3.6_13G37_Restore.ipsw from the website,1/13G37 and used the program 3uTools, but an error message popped up at 85% of the software installation on the phone. I also tried using the program FoneLab iOS Unlocker, but had the same issue.
21:33:52.087: ERROR: device didn't accept BasebandData 21:33:52.140: ERROR: Unable to successfully restore device 21:34:12.648: Failed to restore device(-1) 21:34:12.657: ERROR: Unable to restore iDevice(-1).
I also tried to install older versions of the 3uTools program, but the same issue occurred.
Serial Number: DX7LT3VQFML6 ECID: 000002D93A0DDD0B
The only versions that can be tried are:
9.3.6 9.3.5,1
Older versions written in red letters cannot be installed because "Unable to Request SHSH" appears at 9%.
Until the software is uploaded, the phone can only be in DFU or Recovery mode and is unusable.
I also tried using the original iTunes program to flash the firmware, and it also gave an error message similar to "Baseband Error." I posted about this issue on other forums, and people suggested that the only solution is to physically replace the baseband chip, but I don't have the money and don't know how to do it, so that's not an option. Which program can I use to flash the firmware without having to flash the baseband?