• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Question Extremely low Random IOPS on two SSDs

alexo

Member
Jan 5, 2000
29
0
66
Hello,

I have two Samsung SSDs in my computer, an 840 Pro and 860 Evo, both are connected via a SATA3 interface configured as AHCI.
The motherboard is an Asus P8Z77-V Pro, with an i7-3770K CPU.
TRIM is enabled, MB and drive firmware is the latest.

Both drives report sequential performance slightly less than the advertised, but the random IOPS performance is extremely low, about 1/5 of the advertised.


Samsung Magician data:




CrystalDiskMark 8.0.1 results:

Code:
840 Pro:
--------

[Read]
  SEQ    1MiB (Q=  8, T= 1):   555.696 MB/s [    530.0 IOPS] < 15045.39 us>
  SEQ    1MiB (Q=  1, T= 1):   513.031 MB/s [    489.3 IOPS] <  2040.42 us>
  RND    4KiB (Q= 32, T= 1):    98.627 MB/s [  24078.9 IOPS] <  1290.06 us>
  RND    4KiB (Q=  1, T= 1):    27.112 MB/s [   6619.1 IOPS] <   149.27 us>

[Write]
  SEQ    1MiB (Q=  8, T= 1):   440.866 MB/s [    420.4 IOPS] < 18900.28 us>
  SEQ    1MiB (Q=  1, T= 1):   486.462 MB/s [    463.9 IOPS] <  2148.58 us>
  RND    4KiB (Q= 32, T= 1):    86.295 MB/s [  21068.1 IOPS] <  1469.22 us>
  RND    4KiB (Q=  1, T= 1):    55.701 MB/s [  13598.9 IOPS] <    71.98 us>


860 Evo:
--------

[Read]
  SEQ    1MiB (Q=  8, T= 1):   564.342 MB/s [    538.2 IOPS] < 14817.95 us>
  SEQ    1MiB (Q=  1, T= 1):   528.124 MB/s [    503.7 IOPS] <  1983.09 us>
  RND    4KiB (Q= 32, T= 1):   105.485 MB/s [  25753.2 IOPS] <  1201.47 us>
  RND    4KiB (Q=  1, T= 1):    33.266 MB/s [   8121.6 IOPS] <   121.58 us>

[Write]
  SEQ    1MiB (Q=  8, T= 1):   534.566 MB/s [    509.8 IOPS] < 15597.54 us>
  SEQ    1MiB (Q=  1, T= 1):   498.652 MB/s [    475.6 IOPS] <  2099.09 us>
  RND    4KiB (Q= 32, T= 1):    92.856 MB/s [  22669.9 IOPS] <  1365.49 us>
  RND    4KiB (Q=  1, T= 1):    61.660 MB/s [  15053.7 IOPS] <    64.86 us>
Suggestions are appreciated.

Thank you!
 

Shmee

Memory and Storage, Graphics Cards
Super Moderator
Sep 13, 2008
5,413
1,032
126
From what I can tell, your motherboard should have both Intel and ASmedia 6Gb/s SATA ports. (2 of each.) Are you sure you are connected to the Intel ports? The ASmedia ports will likely not perform as well.
 
Thread starter Similar threads Forum Replies Date
sze5003 Memory and Storage 36

ASK THE COMMUNITY