Epson scanner shenanigans, various Linux distros

mikeymikec

Lifer
May 19, 2011
15,438
5,662
136
AIO printer: WF-3520, normally connected via ethernet and static IP.

I typically use simple-scan, the default gnome scanning app as it best fits my workflow. On Lubuntu 18.04 LTS it worked perfectly. Since upgrading though things have gone a bit squirrelly.

Lubuntu 20.04 and Kubuntu 20.04 LTS:
Fire up the app, tell it to do a scan, it works fine in that the preview is updated more or less in real time as the data comes through, the app is perfectly responsive throughout and I can scan again as the first page is complete (let's say I'm doing flatbed scanning for example). However, let's say I've finished scanning document #1, save it and move on to document #2, so I click on 'start over' to clear the previous scan off the screen and tell it to scan again. The app stops responding for about 30 seconds after the scan is complete. This also happens if I tell it to scan again to scan more pages for the same document.

Debian 11:
The app is perfectly responsive regardless of the amount of times I keep requesting more scans for document #1, but as soon as I 'start over', it claims it can't find the scanner any more. Initially I thought this might have been a VM issue from my main PC but I did a test install on a spare PC and got the same result.

Out of curiosity I then connected the printer via USB to the spare PC and while it didn't lose connection after 'starting over', it did claim that it was an 'unknown model' of Epson scanner, which was odd.

As it's quick enough to try, I just hooked up the printer to my main PC via USB, made the modifications necessary on Kubuntu to switch the scanner connection to USB, disconnected the scanner's network connection (mainly to play it safe) and while the app still goes non-responsive during scanning, the delay before returning to normal after the scan is only about 5 seconds.
 

ASK THE COMMUNITY