• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Doom wont run in Vulkan

Rifter

Lifer
Oct 9, 1999
11,519
745
126
So ive been trying to get doom running in vulkan for a few days not and have had no success. When i change to vulkan it crashes on boot and gives me a error report saying vulkan failed to start.

Looking around the net i am far from the only person with this issue. I can edit the config file to go back to openGL render but this does not solve the problem of not being able to use vulkan.

I have the latest drivers installed and vulkan is installed, i have tried the last 3 driver versions with the same result.

It has been mentioned in some reading i have done online that this is due to nvidia driver not cleaning up after itself somewhere in the registry(i upgraded to rx480 from SLI GTX 460 so had nvidia drivers installed on this OS previous) and most people with this problem seem to be the same, had nvidia card at some point.

Anyone know where exactly to look into the registry to stop Nvidia from letting me play doom with vulkan?
 

Elixer

Lifer
May 7, 2002
10,377
762
126
Use DDU (Display Driver Uninstaller), then reinstall the AMD drivers.
 

Rifter

Lifer
Oct 9, 1999
11,519
745
126
Found solution. I was right, it is Lazy Nvidia programmers not cleaning up after themselves. Or its a deliberate attempt to sabotage people switching to AMD by removing the ability for later installed AMD drivers to use vulkan API. Who knows.

Either way to fix this go here in the registry:

HKLM\SOFTWARE\Khronos\Vulkan\Drivers

there will be a link to a json file in there, open the json file and it will probably say some nvidia .dll in there like mine did, even though i uninstalled all nvidia drivers and ran DDU(thanks lazy nvidia programmers!). So since it cant load that nvidia .dll because the .dll was removed it will not load any vulkan games.

To fix this replace the nvidia .dll in the json file with:

"
{
"file_format_version" : "1.0.0",
"ICD": {
"library_path": ".\\amdvlk64.dll",
"abi_versions" : "1.0.0"
}
}
"

Once your json file looks like the above then you will be able to use vulkan API with your AMD card again.
 

ASK THE COMMUNITY