Doom III framerate hiccups

Kenjura

Junior Member
Oct 2, 2000
22
0
0
I seem to be having a problem in Doom 3. The framerate is consistent most of the time, but every now and then the whole game freezes for a second or so, usually when a bunch of monsters appear. It's extremely noticable in timedemo. It kind of takes away from the experience.

Where is the bottleneck?
Asus P4C800-E @ 250MHz FSB
Pentium 4 2.4 Northwood @ 3.0 Ghz
Corsair TwinX 256(x2)MB DDR 500 @ 500 Mhz
BFG Geforce 6800 OC @ factory default
Western Digital 36 GB Raptor

I'm running at 1024x768 High Quality, and getting around 32 fps, except, of course, when it freezes.

Anyone else have this problem?
 

Smilin

Diamond Member
Mar 4, 2002
7,357
0
0
It's pretty normal to see that in the timedemo. No worries there. Run the demo twice back to back and you shouldn't really see it the second time through.

If you are seeing it in-game that would be an issue. I'm not seeing any real bottlenecks on that system (Assuming that BFG is 256MB. I *think* a 128mb card might texture thrash a little on high quality).

How bad is it in-game?? Only thing I can think of is something might be failing and performing a retry because of overclocking. Check your system event logs to see if you are getting any errors around that time. If you are getting any events you might clock down a bit. This hypothosis is a bit of a stretch though.
 

BFG10K

Lifer
Aug 14, 2000
22,689
2,898
126
Add '1' to your timedemo command to precache the data and that'll stop it stuttering. Also consider getting 1 GB RAM and not overclocking.
 

Kenjura

Junior Member
Oct 2, 2000
22
0
0
Well, "timedemo demo1 1" certainly got rid of the hiccups (in the demo, anyway), but now I have a new problem. My flashlight doesn't work! As in, it sheds no more light than my ugly face. You can imagine the difficulties. The problem started after I changed some video settings (just AA/AF), but no changes I make now will bring it back.

Any ideas?