does nvidia patch force gen 3.0 work on 700 series? and will it on 800?

Discussion in 'Video Cards and Graphics' started by brandon888, Oct 26, 2013.

  1. brandon888

    brandon888 Senior member

    Joined:
    Jun 28, 2012
    Messages:
    537
    Likes Received:
    0
    I have lga 2011 with I7 3930K ... i im on GtX 660 atm and using nvidia force gen patch 3.0 ... on gpu-z i see pci 3.0 versin and everything works great ... but for 700/800 series will that patch work or i will stuck with pci 2.0?
     
  2. FiLeZz

    FiLeZz Diamond Member

    Joined:
    Jun 16, 2000
    Messages:
    4,626
    Likes Received:
    0
    yes I use it on my 780 cards. Some times I have to manually reg edit as well.
     
  3. brandon888

    brandon888 Senior member

    Joined:
    Jun 28, 2012
    Messages:
    537
    Likes Received:
    0

    No idea how to do it manually but if it works on 600/700 series it will work also on 800s to yes ? Cause it does not depend on GPU as i understand ... it just have to be activatet on CPU with 40 lanes ... is thay correct ?
     
  4. BrightCandle

    BrightCandle Diamond Member

    Joined:
    Mar 15, 2007
    Messages:
    4,763
    Likes Received:
    0
    Not all the 3930k's actually support PCI-E 3.0. Many failed to meet the spec and hence NVidia disabled the 3.0 support on the platform. Forcing it could cause instability and from what I have seen brings no performance benefits.
     
  5. ViRGE

    ViRGE Elite Member, Moderator Emeritus

    Joined:
    Oct 9, 1999
    Messages:
    31,078
    Likes Received:
    8
    Yes, it works on the 700 series as well. It's a generic routine; it searches out all NVIDIA GPUs and sets the registry flag required to tell the driver to use PCIe 3 if it's available (regardless of whether it's officially supported or not).