• Hey there Guest! This holiday season you have a chance to win some cool AnandTech swag! Check out “The Holiday Hotlist” giveaway, which you can find here.

DHCP server keeps using up all IP's in scope - Need help

milagro

Golden Member
Jun 19, 2001
1,459
0
0
#1
I have a server on my LAN designated to use 192.168.0.4. For the other pcs on the LAN I have a scope of 192.168.0.5-10. There are currently only two clients on the network. They are configured to use DHCP and are usually found using 192.168.0.6 and 192.168.0.7. Occasionally, I'll lose my connectivity on one of the clients (probably because the lease expired). When I go examine the DHCP server, I find that the server is using all of the IP's in the scope simultaneously, preventing the clients from getting a connection.

What causes this and does anyone have a solution?

thx
 
Nov 21, 2001
18,100
0
116
#2
that is bizzare. turn off dhcp client on that server, and your problem should go away. (dhclient in unix)
 

milagro

Golden Member
Jun 19, 2001
1,459
0
0
#3
Thanks for the reply. I'm glad i'm not the only one who finds it bizarre...surprised no one else has experienced it..been digging around on google for awhile and can't find anything..

To my knowledge, the server isn't running dhcp client as I have manually defined its ip/network parameters. Everything is behind a netgear mr814 router which apparently needs the firmware updated...maybe its related to that. Normally the router can server ip but in this case its just a gateway and i set up the server as dhcp server. I'll check it all out again when I get home..
 

milagro

Golden Member
Jun 19, 2001
1,459
0
0
#4
Man I still have this problem. To troubleshoot, I changed the lease time to one minute. The server uses up all the ip's remaining in the scope as soon as I delete the client leases...

what's going on?

Also, the icon for the leases being used for the server looks slightly different...the "real" clients just have pc icons but the server icons look like a phone with a pc/arrow...

any help appreciated..
 
Nov 21, 2001
18,100
0
116
#5
tell me about your dhcp server, and your server that is hogging addresses. what OS? What router?
 

milagro

Golden Member
Jun 19, 2001
1,459
0
0
#6
I have a netgear mr814 configured with latest firmware identifying my w2k server as the dhcp server (192.168.0.4). The ip settings for the dhcp server were mannually entered (not using DHCP). The dhcp server is also running active directory, dns, etc for two clients, one of which is wireless. The router is identified as both the gateway and a dhcp relay agent. The available scope is 192.168.0.5-10. The router is 192.168.0.1.

One client is using w2k and the other xp. I have been using this network for testing.
 
Nov 21, 2001
18,100
0
116
#7
So the DHCP server is also the beast that is consuming all available IP's? Man, that is too strange. I have no clue, have you tried knowledge base for 2k server?
 

milagro

Golden Member
Jun 19, 2001
1,459
0
0
#8
i've tried looking but its kind of a difficult topic to search for...One thing i noticed was I was fooling around with DNS settings a long time ago and noticed I had setup a reverse lookup zone. Since its not really necessary in this case, I deleted it and so far so good...but its hard to say if changes I make do the trick initially as it can take a couple days for the problem to show up again...even if I set lease periods to a couple minutes.. Next time it happens I'll try to post a screen shot if possible..
 

milagro

Golden Member
Jun 19, 2001
1,459
0
0
#9
Here's another thought, I was forwarding ports on my router for a website and ftp...perhaps its related to that. I don't need the services now so I've closed the ports and will see how that works..
 

azev

Golden Member
Jan 27, 2001
1,003
0
0
#10
You know it is possible that your dhcp server is reserving some IP's for Routing and Romote access service.
Are you using VPN ?? if not try disabling the service than it should take care of your problems. RRAS reserve the first 10 available IP address for VPN or for dial up when setup(the phone icons). Let us know if that fix your problem.
 

milagro

Golden Member
Jun 19, 2001
1,459
0
0
#11
Originally posted by: azev
You know it is possible that your dhcp server is reserving some IP's for Routing and Romote access service.
Are you using VPN ?? if not try disabling the service than it should take care of your problems. RRAS reserve the first 10 available IP address for VPN or for dial up when setup(the phone icons). Let us know if that fix your problem.
That's right...had forgotten about that...well I had to activate RRAS for the relay agent..so that may be it. So if thats the case, I should be able to expand the scope but only have up to 10 consumed w/ the server IP correct?..
 

azev

Golden Member
Jan 27, 2001
1,003
0
0
#12
well just add more IP address to your scope. Use more 10+whatever the number of computer you're going to use. Try to delete the scope and create new one, do not just add more ip's to an existing scope.
That should do it.

Good luck.
 

wlee

Senior member
Oct 10, 1999
585
0
71
#13
It sounds like you prob have Network Load Balancing enabled on one or more servers. That would cause them to hog up EVERY avail DHCP IP. It uses the IP's to create virtual MAC/NetworkCards.
 

martind1

Senior member
Jul 3, 2003
777
0
0
#14
why does the router have dhcp relay on?
 

MysticLlama

Golden Member
Sep 19, 2000
1,003
0
0
#15
I'll second that on the VPN situation.

It takes up 10 IPs on my W2k server as well, and as soon as I saw that your range was 10 and the server was taking them all that's the first thing that popped to mind.
 

ASK THE COMMUNITY