• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Creative Sound Blaster Z series not working with Tosklink/SPDIF

Devilz_soul

Junior Member
Jan 9, 2015
16
0
66
Background:

My Rig
Processor: AMD FX8320
Motherboard: Asus M5 A99FX Pro R2.0
Ram: 32 Gig DDR3
Video Card: Radeon R9 200 Series (PCIe 2.0 x16 slot, blue color)
Sound Card : Creative Blaster Z (PCIe x4 mode, black color)

Os: Win 8.1

I have hooked up this rig to my Denon A/V 2809CI Reciever via HDMI coming out of Radeon R9 and Optical/Toslink from Creative Blaster Z.

The Problem

I want to bang my head on the desk while writing this, I am not getting any sound to my AV Reciever when I am using TosLink for Creative. I tested that the Microphone, headphone, 3.5 mm jacks work, I can hear sound through them when I insert my headphone. But Not through Optical.

I have disabled onboard Sound via bios, didn’t install the HDMI Audio chip drivers that Radeon have. I, did however, notice that in my control panel → Sound, I do see a TV sign with[AMD HDMI high definition sound] option and when set to default and test it, AV receiver gets a stereo signal. But when I setup Creative Blaster Z series Speakers as default (After reading on forums all over, it seems like you set the Creative speakers as default and Creative automatically kick off SPDIF output, shrugs I don’t know how creative is still a company at this stage with this sort of convoluted ways). So yeah, when I setup the Creative Blaster Z series as default and do a test, My receiver don’t receive any sound, I can however listen to it via Headphone jack or 3.5 mm jack on the card.

Resolution steps.
- Made sure that Sound and Video cards are not sharing channels, can share pics if that help. Not using PCIe slot because Vdo card was covering it.
- Uninstalled and wiped the whole system. Reinstalled Windwos 8.1, MB drivers (excluding Audio), Video and Audio drivers. Still same result, Setting SB speakrs as default wont get me any sound, Setting the HDMI High definition as default will send crappy stereo signal.

Where I am stuck.
- I cant for the life of me figure out how to get my toslink/SPDIF to work, it is clear from all the testing that soundcard work on analog.. just not on TosLink/spdif. One of the forums suggesting was to switch on the Dolby or DTS to ensure that SB Z is forced to use SPDIF but I get a nice error message saying “the task requires exclusive use of your audio device” – I went into Sound under control panel and switched off the “exclusive use” tick box both under Spdif and Speakers for Creative.. but same error keep coming up and I am at loss

I am extremely frustrated because I don’t know what else to do … I am not sure what else I can do to get this thing working and I feel that it is a bit too early to burn the whole rig down ……so any help that you can provide would be great.. I just want creative to behave and send me a 5.1 channel signal via Toslink


Side notes:
- Yes, I did change the Spdif/Toslink cable to check if it works well.
- Reslotted both cards
- My AV receiver can take multiple input for the same A/V channel (my older system was similar but with GeForce and Razer Baracuda sound card)

Let me know if I can send pictures to help out some sort of diagnosis
 

stockwiz

Senior member
Sep 8, 2013
403
15
81
To get sound to work from optical to say a Surround Receiver you have to go into the Sound Blaster Z/ Creative Control panel under the "Cinematic" tab and change the settings to either "Dolby Digital Live" or "DTS Connect" ... then you have to go into your windows sound settings and make sure you are using "Speakers" and not "SPDIF Out" for the Sound Blaster Z. I'm assuming you have the TOSLINK cable going where it needs to go on your receiver with the correct mode chosen.

The "play stereo mix to digital output" in the advanced features should be unchecked.

In the Speakers/Headphones Tab, make sure "5.1 Surround" is chosen with the appropriate speakers selected. They will most likely not be full range speakers so leave that unchecked. If you have a subwoofer using the bass redirection subwoofer gain along with selecting a crossover frequency are recommended.

If you're trying to get sound to a home theater receiver with toslink using "No Encoder" you're doing it wrong... TOSLINK cannot handle the bandwidth of 5 discrete channels of sound uncompressed and must be encoded by the software to work with 5 channels, period. There's no way around that.




Off topic part:

Since I have a receiver and living room 5.1 setup I've found disabling my sound card and doing HDMI out from my GTX 970 sounds quite a bit better. I don't get some of the extra settings that the Sound Blaster Control panel has but most of my FLAC and especially the SACD 5.1 FLAC and .dff stuff I have seem to have better sound clarity and definition especially if I set it to 24 bit 96000hz in the windows volume settings and of course having the speakers set at "5.1" in windows volume settings my receiver sees the signal as "PCM MULTI CH HDMI" and I get whatever channels are sent from the PC depending on what content I'm viewing unless I use one of the receiver's custom settings that mixes it to all the channels which I avoid. HDMI can handle quite a bit more bandwidth compared to Toslink so I suppose the better clarity makes sense.
 
Last edited:

ASK THE COMMUNITY