Correcting Windows Update behaviour

lupi

Lifer
Apr 8, 2001
32,542
260
126
Was late getting up this morning as my computer decided to reboot itself and the alarm isn't active until youve logged in. I know I previously had update set to inform and manually download. How do I reinstitute this type of setting or prevent these unrequested reboots.
 

mikeymikec

Lifer
May 19, 2011
13,554
3,239
136
Was late getting up this morning as my computer decided to reboot itself and the alarm isn't active until youve logged in. I know I previously had update set to inform and manually download. How do I reinstitute this type of setting or prevent these unrequested reboots.
If it's a version of Windows older than Win10:

Control Panel > Windows Update > Change Windows Update Settings

If it's Windows 10:

AFAIK you can't do it. There's a number of things you could do instead, but not that.

I think the gentlest option would be to alter the 'active hours' setting to suit your needs so therefore Windows won't auto reboot during hours that would be inconvenient for you, though I find it irritating that (at least the last time I looked at that feature) MS insists on having an upper limit for the number of active hours per day that's nowhere near 24.

In your case to use the computer as your alarm clock where presumably the alarm goes off at a reasonably normal morning hour you might have to look at the 'active hours' feature the other way around being to set it to night-time hours so in theory it won't reboot during the night.

Another option based around active hours is not to have a login password so Windows just logs straight in and therefore your alarm is active.

Another option under Settings > Windows Update is the pause updates option. The first option you see allows you to pause updates for 7 days, another under advanced settings allows pausing for 35 days apparently. You could then unpause, hand-hold it through updating, reboot, then pause updates again?
 

crashtech

Diamond Member
Jan 4, 2013
9,512
1,413
126
It can be done with Windows 10 Pro, but not Home, afaik. I have instructions for Pro somewhere, but want to OP to verify his version first.

I don't think using Windows as an alarm clock at this point is a winning proposition.
 

Insert_Nickname

Diamond Member
May 6, 2012
3,800
477
126
Another option under Settings > Windows Update is the pause updates option. The first option you see allows you to pause updates for 7 days, another under advanced settings allows pausing for 35 days apparently. You could then unpause, hand-hold it through updating, reboot, then pause updates again?
That's what I'd recommend. Then you can run updates at your convenience, then re-pause when done. As long as you do that once a week, Windows shouldn't complain too much. My HTPC doesn't at least.

You'll need to be on 1903 or later to use that feature however. But time has almost run out for 1809, so it shouldn't be an issue.
 

mikeymikec

Lifer
May 19, 2011
13,554
3,239
136
It can be done with Windows 10 Pro, but not Home, afaik. I have instructions for Pro somewhere, but want to OP to verify his version first.

I don't think using Windows as an alarm clock at this point is a winning proposition.
AFAIK Win10 Pro allows you to defer an update (which is handy for potentially immature and destructive feature updates), but not a lot else.
 

crashtech

Diamond Member
Jan 4, 2013
9,512
1,413
126
AFAIK Win10 Pro allows you to defer an update (which is handy for potentially immature and destructive feature updates), but not a lot else.
I know for certain it can be done on earlier versions of Win10 via the Group Policy Editor, but I'm not certain if MS has "fixed" this in later versions. I'm not able to access my notes at the moment, but I'll share the info later if there's interest.
 
  • Like
Reactions: mikeymikec

crashtech

Diamond Member
Jan 4, 2013
9,512
1,413
126
Here's the note I have that has worked for me in the past:
Using the Group Policy Editor to delay Windows Updates:


Open the Run command (Win + R), in it type: gpedit.msc and press enter

Navigate to: Computer Configuration -> Administrative Templates -> Windows Components -> Windows Update

Open this and change the Configure Automatic Updates setting to ‘2 - Notify for download and notify for install’

Open the Settings app (Win + I) and navigate to -> Update and Security -> Windows Updates. Click ‘Check for updates’ which applies the new configuration setting
Restart
It has worked for me in the past, but since my focus has been on migrating worker PCs to Linux, I don't know for sure if it works on the latest updates. But when successful, it stops unauthorized reboots. Keep in mind that with every new major update/upgrade (which should be manually completed) you need to re-verify that these settings have not changed.
 
  • Like
Reactions: mikeymikec

mikeymikec

Lifer
May 19, 2011
13,554
3,239
136
One thing I found funny with Win10 as the gaming OS on my own machine is that it basically 'suffers' from exactly the same thing as Windows has done for years on many of my customers' computers: They switch it on, do a couple of things on it, then immediately shut it down. It might be active for about 20 minutes, which is rarely enough to get maintenance jobs done.

On my own PC, I only boot into Win10 when gaming then I immediately reboot. I've had warnings that my version of Windows 10 won't receive updates any more because a feature update hasn't been done in so long, despite me sometimes gaming for hours.
 

crashtech

Diamond Member
Jan 4, 2013
9,512
1,413
126
One could always download the latest iso and install it manually as an upgrade.
 

ASK THE COMMUNITY