Question Computer won't start

red7silence

Junior Member
May 24, 2020
1
0
6
My specs: Ryzen 3600x, 64 gigs of ram rated at 3600 mhz, 1080, Tomahawk 450.

So I just upgraded to the 3600x, and I was originally having issues because the bios. I updated it, got it working. Then I went to overclock it. It was at 4.2, and it was rated at 4.4, so I manually set it to 4.4. I also set the profile X-AMP, which set my ram sticks to 3600. However I realized afterwards the the tomahawk only supports up to 3466 mhz.
So after I restarted the computer, it wouldn't post to BIOS. It wouldn't even show a screen to my TV. My video card fans would spin for about a minute then stop. The lights next to the power button won't turn on, but all the lights inside the motherboard will.

So I'm wondering what the issue is. I've cleared motherboard battery for 45 minutes, I've tried all the ram sticks in different slots, I've tried everything. I can't figure out the issue. I also installed my old CPU, 1700x, and it still did the same thing. I even did a Flash BIOS update.

So would pushing my RAM above the motherboards max settings cause this? Wouldn't I be able to just reset BIOS to default?
Would it be my CPU? I changed to my older CPU and still same issue.
Is it my motherboard? Wouldn't it just not power on at all?
 

DrMrLordX

Lifer
Apr 27, 2000
15,802
4,775
136
You've probably got a corrupted UEFI. Reflashing the UEFI should have fixed it. In theory you might have nuked the CPU but I doubt it. BTW a 3600x is only rated for 4.4 GHz on one core. Not all of them . . . how much voltage did you give the chip?
 
  • Like
Reactions: JPB

ASK THE COMMUNITY