CoD4 MW Problem


Junior Member
Apr 7, 2020
Hello all, I'm Dave!!! This is my first time posting here so please take that into mind.

I have been playing CoD for about 5 years or so now and recently have had this problem. First of all, I did not download CoD from steam, but rather bought the CD to install the game. It is legit and not downloaded or hacked or anything like that.

So, as I said, I've played for a while with no problems. I played it on a computer I had just before the one I'm using now as I recently upgraded (built a new machine) in trying to stop this problem from happening. When I had this problem crop up, I tried the following steps to find out what the problem was:

1. Bought a new video card (old card was a Radeon Sapphire Nitro - The new card (which is the one I'm using now and used in the previous machine is an NVidia GeForce one:
2. Tried uninstalling and reinstalling the game (several times)
3. Tried running it with no other drives attached in the machine

So, here is the problem.
I play a problems in game play I might add and the map ends. The title of the new map comes up and if don't have the map file on my machine the download proceeds and I get all 3 files needed. I believe it's on the download of the third file that the download stops and I have a windows cursor on the screen (that I can move around with my mouse) and it just hangs there. I hit Alt-Tab and I can see that windows is trying to open up multiple instances of CoD instead of just rolling over into the game I have open and was already playing. Eventually, an error comes up saying something like "The program has encountered an unexpected error and has shut down" and I can click the "OK" button and I'm back at my desktop.

I can then re-launch the game and it goes right into the map that I was just downloading and plays fine. I've also noticed that it seemed to be working fine on the new computer that I just built. I installed the game and it was running fine.....going from map to map with no problem. Then the damn problem reared it's ugly head again and I'm back to having to relaunch the damn game every time the map changes!!

I don't have a dxdiag file from my old machine but I'll post the one from my new computer here to help with solving this irritating problem. I'm really believing this is a MOD problem with the server I'm playing on now (although I was playing on another server with my old machine and was having the problem there too.)

I hope all this information is what someone might need to help me solve this problem. If it's not, please just contact me and I'll try to provide whatever else is needed!!

Tech Support Guy System Info Utility version
OS Version: Microsoft Windows 10 Home, 64 bit, Build 18363, Installed 20200315113909.000000-240
Processor: AMD Ryzen 5 3600 6-Core Processor, AMD64 Family 23 Model 113 Stepping 0, CPU Count: 12
Total Physical RAM: 16 GB
Graphics Card: NVIDIA GeForce GTX 1050 Ti
Hard Drives: C: 930 GB (783 GB Free); D: 1397 GB (775 GB Free); F: 1862 GB (1862 GB Free);
Motherboard: Gigabyte Technology Co., Ltd. B450 AORUS M, ver x.x, s/n Default string
System: American Megatrends Inc., ver ALASKA - 1072009, s/n Default string
Antivirus: Windows Defender, Enabled and Updated

Any and all help or suggestions are appreciated!