Cisco Router PPPOE

crunchcable

Junior Member
Sep 6, 2007
5
0
0
Hi,


I would like to use a Cisco router to dial in to a PPPOE service and configure a static default route to the service provider. This should make connected networks packets that are forwarded to the router be sent out to the service provider.

Is this possible to do?

 

JackMDS

Elite Member
Super Moderator
Oct 25, 1999
29,513
407
126
I do not know what kind of DSL service you have, and which Cisco Router you are using.

PPPOE is Not actually "Dialed". When one subscribes to DSL service the Internet service is "pushed" onto the telepone line all the time.

The PPPOE establish the connections by providing ID and password to the service.

Static IP is Not something that you decide upon. If you are paying for static IP service your ISP should provide you with IP number and this number should be used to enter into the Router while comfiguring it.

http://www.dslreports.com/faq/8199




 

crunchcable

Junior Member
Sep 6, 2007
5
0
0
The IOS is version 12.3 and I want to use an Ethernet port on the router to connect to my dsl modem.

Usually I just use the windows pppoe client to connect to the service but I want to practice using cisco routers so I thought this would be something to try, I do have to use a username and password to login.

If I can get the router to log in to the service, I could network computers to the router and make a static-default route to the service provders gateway to the internet?
 

crunchcable

Junior Member
Sep 6, 2007
5
0
0


------------------------------------------------------------------
Configuring a PPPoE Client on an Ethernet Interface

Perform this task to configure a PPPoE client on an Ethernet interface.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface ethernet number (just random chosen, ethernet 0?)

4. pppoe-client dial-pool-number number (the dialer # I configure below??)

-------------------------------------------------------------------------
This will make the ethernet interface use the PPPOE dialer?

and

-------------------------------------------------------------------------
Configuring the Dialer Interface

Perform this task to configure the dialer interface to be used for cloning on the PVC.
SUMMARY STEPS

1. enable

2. configure terminal

3. interface dialer number (dialer that is used for first part?)

4. mtu bytes (1500?)

5. ip address negotiated (because it's assigned by service right?)

6. dialer-pool number ( I'm confused about this number?)

7. dialer-group group-number (don't understand what this is for either)

--------------------------------------------------------------------------------


Thanks for the help with this, my instructor hasn't cover dialers yet. I also don't understand where I put in the username and password?
 

jlazzaro

Golden Member
May 6, 2004
1,743
0
0
interface Fa0/0
description DSL interface
no ip address

pppoe enable # enable pppoe on the interface
pppoe-client dial-pool-number 1 # ties the interface to the dialer interface
!
interface Fa0/1
description Internal interface

ip address 172.16.1.1 255.255.255.0 # your internal ip space
ip nat inside # specify this as an internal nat interface
!
interface Dialer1
ip address negotiated

ip mtu 1492 # accounts for PPP overhead
ip nat outside # specify this as an external nat interface
encapsulation ppp
dialer pool 1 # places logical interface into the dialer pool
ppp authentication chap callin # enable unidirectional chap authetnication
ppp chap hostname cisco
ppp chap password s3cr3t

ip route 0.0.0.0 0.0.0.0 Dialer1 # default route to the dialer interface
access-list 100 permit ip 172.16.1.0 0.0.0.255 any # ACL for your NAT traffic
ip nat inside source list 100 interface Dialer1 overload # NAT overload statement

verify with:
show pppoe session
show pppoe summary



debug with:
debug pppoe events
debug ppp negotiation
debug ppp authentication