Cisco - Enable QOS through DSCP and dump to priority queue

poohbeer

Junior Member
Mar 24, 2001
7
0
0
Situation: 2 VOIP PBX's connected over a network with some cisco 2950 and 3550 switches inbetween (among others). QOS is needed to keep jitter at a minimum.
I'm trying to config a catalyst 3550 right now.

PBX's set dscp=46 themselves so do not need to mark incoming traffic.

According to http://www.cisco.com/univercd/cc/td/doc...22/122cgcr/fqos_c/fqcprt7/qcfdfsrv.htm I can do this with class-maps, policy-maps and service policies.


So class map:

Switch(config)#class-map match-all voip46
Switch(config-cmap)#match ip dscp 46

policy map:

Switch(config)#policy-map voip46
Switch(config-pmap)#class voip46

Now I should be able to give a priority command. Unfourtunatly, no go.

Code:
Switch(config-pmap)#class voip46
Switch(config-pmap-c)#?
QoS policy-map class configuration commands:
  bandwidth  Bandwidth
  exit       Exit from QoS class action configuration mode
  no         Negate or set default values of a command
  trust      Set trust value for the class
  <cr>
  police     Police
  set        Set QoS values

Only available is bandwidth which doesn't help since it does not forward to the priority queue and hence does northing to limit jitter. Why doesn't the priority command show here? Anyway to solve my problem?
 

bgroff

Member
Jun 18, 2003
198
0
0
I hope for your sake you have Enhanced 2950s. Otherwise your QoS possibilies are limited.

Here is info on 2950 QoS.

Here is info on 3550 QoS.

When it comes to QoS remember that it doesn't do anything until there's congestion. And you probably don't really need to do much more than set up priority queues and trust the ports the PBXs are on as well as the uplink ports on the switches.

 

Cooky

Golden Member
Apr 2, 2002
1,408
0
76
Why doesn't the priority command show here?
I think the Priority command is available under policy-map only on WAN routers.

In your case you can use "trust dscp" under policy-map, and then use "priority-queue out" to enable strict-priority queuing.

I hope this somewhat helps.
 

poohbeer

Junior Member
Mar 24, 2001
7
0
0
Originally posted by: bgroff
I hope for your sake you have Enhanced 2950s. Otherwise your QoS possibilies are limited.

Here is info on 2950 QoS.

Here is info on 3550 QoS.

When it comes to QoS remember that it doesn't do anything until there's congestion. And you probably don't really need to do much more than set up priority queues and trust the ports the PBXs are on as well as the uplink ports on the switches.

The 2950's do have the Enhanced Image yes. No worries there.
The way I understand it is that jitter can kill a voice application no matter how much bandwidth you've got and that's what we're trying now.
Dump any traffic with dscp=46 into a priority queue so it gets as little delay as possible.


Originally posted by: Cooky
Why doesn't the priority command show here?
I think the Priority command is available under policy-map only on WAN routers.

In your case you can use "trust dscp" under policy-map, and then use "priority-queue out" to enable strict-priority queuing.

I hope this somewhat helps.

trying that, still no go.
The config:

***********************
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable password cisco
!
ip subnet-zero
!
mls qos
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
class-map match-all Voice
match access-group 101
!
!
policy-map Ingress-Policy
class Voice
trust dscp
!
!
!
interface FastEthernet0/1
switchport mode dynamic desirable
mls qos monitor dscp 0 46
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 3
wrr-queue cos-map 3 4
wrr-queue cos-map 4 5 6 7
priority-queue out
service-policy input Ingress-Policy
!
interface FastEthernet0/2
switchport mode dynamic desirable
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 3
wrr-queue cos-map 3 4
wrr-queue cos-map 4 5 6 7
priority-queue out
!
interface FastEthernet0/3
switchport mode dynamic desirable
!
interface GigabitEthernet0/1
switchport mode dynamic desirable
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
!
interface Vlan1
ip address 10.0.2.111 255.255.255.0
!
interface Vlan10
no ip address
!
ip classless
ip http server
!
access-list 101 permit ip any any dscp ef
!
line con 0
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
!
end
******************************

But i must be forgettign something obvious:


Switch#sh queueing interface fa0/1
Interface FastEthernet0/1 queueing strategy: none
Switch#sh queueing interface fa0/2
Interface FastEthernet0/2 queueing strategy: none


And the output to this is not entirely clear to me.

Switch#sh mls qos interface Fa0/1 statistics
FastEthernet0/1
Ingress
dscp: incoming no_change classified policed dropped (in bytes)
0 : 1037482 1037482 2347651 0 0
46: 51340335 48992940 0 0 0
Others: 5259285 5257356 1673 0 0
Egress
dscp: incoming no_change classified policed dropped (in bytes)
0 : 47354638 n/a n/a 0 0
46: 62 n/a n/a 0 0
Others: 5362380 n/a n/a 0 0


And why oh why:

Switch#sh int fa0/1
...
input flow-control is off, output flow-control is unsupported
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
 

Cooky

Golden Member
Apr 2, 2002
1,408
0
76
What if you change "access-list 101 permit ip any any dscp ef" to "access-list 101 permit ip any any dscp 46"??
 

poohbeer

Junior Member
Mar 24, 2001
7
0
0
Originally posted by: Cooky
What if you change "access-list 101 permit ip any any dscp ef" to "access-list 101 permit ip any any dscp 46"??

dscp 46 = ef (expidited forwarding). same thing. And same results.
Well, as far as I can see. Untill I find a command that's shows traffic flow for the 4 queues I cannot be certain.