Can't install Win 10 or new build.

Charmonium

Diamond Member
May 15, 2015
5,619
388
96
#1
I rebuilt my Ryzen I computer with a new Asus Prime X470-Pro motherboard. When I go to install Win10, It shows me the two Samsung NVMe disks that are installed (m/b has 2 NVMe slots). Both are 250gb and identical part number. I also have a WD red 6T hdd installed. This also shows up.

Unfortunately, Windows won't let me install on any of these drives but it doesn't tell me why.

I had the same problem with the previous board. Both are UEFI.

Does anyone have any idea what I have to do to get windows to install on any of these drives? Any help is appreciated.

It might be worth mentioning that I also can't install Win7 on either of these m/bs. But in the case of Win7, the NVMe drives don't even show up in the list of available locations.
 

UsandThem

Super Moderator
Super Moderator
May 4, 2000
9,670
1,331
136
#3
Also, you really should only have your drive that you are going to install the OS onto installed. Otherwise, Windows can give you some headaches about where it installs everything to.
 

vailr

Diamond Member
Oct 9, 1999
5,296
46
91
#4
If the bios setup has a "CSM: enabled/disabled" setting, check that it's set to "disabled".
 
Aug 25, 2001
41,723
3,099
126
#5
If you are booting the install media "Legacy", but have GPT partitions on those drives, or vice-versa (booting UEFI, and have MBR partitions on those drives), then that could be the problem.

One way to fix that, is at the Disk selection screen, hit SHIFT+F10, to bring up Command Prompt (Admin), and then type DISKPART, and then use DISKPART to CLEAN the disk.

(
LIST DISK
SELECT DISK #
LIST DISK (disk should show as selected)
CLEAN
EXIT
EXIT
)
 

Charmonium

Diamond Member
May 15, 2015
5,619
388
96
#6
OK. I disabled CSM which I assumed would constitute disabling UEFI from what I've read. But when I reboot I get this message and CSM is turned back on. There's no way to get around this.

Also I have OS set to Windows UEFI but I've also tried Other OS.
g8DRMQ0.jpg
 

Charmonium

Diamond Member
May 15, 2015
5,619
388
96
#7
If you are booting the install media "Legacy", but have GPT partitions on those drives, or vice-versa (booting UEFI, and have MBR partitions on those drives), then that could be the problem.

One way to fix that, is at the Disk selection screen, hit SHIFT+F10, to bring up Command Prompt (Admin), and then type DISKPART, and then use DISKPART to CLEAN the disk.

(
LIST DISK
SELECT DISK #
LIST DISK (disk should show as selected)
CLEAN
EXIT
EXIT
)
I tried finding someplace where it would allow me to select legacy but I can't find anything. All I can do is enable or disable raid. There's also an option for AHCI
 
Aug 25, 2001
41,723
3,099
126
#8
I tried finding someplace where it would allow me to select legacy
When booting a USB install stick with Windows 10, make the stick using the MS Media Creation Tool, then boot it using the BIOS/UEFI boot hotkey for the Boot Menu. The USB stick should be listed twice, once with the name of the USB stick, and once with the same name, with "UEFI:" prefixed to it. The Legacy boot mode is the stick without the "UEFI:" on it.
 

vailr

Diamond Member
Oct 9, 1999
5,296
46
91
#9
I disabled CSM which I assumed would constitute disabling UEFI from what I've read.
No: disabling CSM ("Legacy") enables UEFI. The video card is evidently not supporting UEFI, so either replace the video card with one that does support UEFI, or be content with a non-UEFI ("CSM enabled") setup.
Some bioses have a "Legacy + UEFI" / "UEFI" option setting.
Note: in some cases, the video card firmware can be flash updated to support UEFI.
What video card is being used?
It may seem odd that the choice of video card can affect the ability to use an NVMe SSD, but that's the way UEFI works.
If the CPU includes it's own video output, then that could be used instead of the non-UEFI video card. Remove the non-UEFI video card for that setup to work.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS