Can't flash custom TWRP recovery image on Motorola Moto G7 Power phone

chrstrbrts

Senior member
Aug 12, 2014
518
0
81
#1
I've got a brand new Motorola Moto G7 Power running Android 9.

I also have Ubuntu 19.04 running on my desktop.

I want to root the phone.

I've managed to unlock the bootloader using Motorola's online instructions and the adb and fastboot utilities that come with Linux.

The next step is to flash a custom recovery application on the recovery partition.

I'm trying to flash twrp-3.3.0-0-river.img, a new image that I grabbed from here.

When I tried to use fastboot to flash the image, I got this error:



After this failed attempt, I attempted to put my phone into recovery just to see what would happen.

What I got was a screen displaying the Android mascot on its back with its chest plate opened and a black exclamation point inside a red triangle.

The words "No Command" were displayed underneath the graphic.

After waiting a few minutes, the phone, on its own, booted normally.

My phone's OS seems to operate perfectly fine.

I can only surmise that whatever was originally on my recovery partition from the manufacturer has been wiped and there is now nothing on the recovery partition at all.

So, I decided to see if I could boot into the TWRP image directly without flashing it.

So, I ran this in the terminal window: fastboot boot twrp-3.3.0-0-river.img

I received this as a response:



There didn't seem to be any errors.

The phone, however, switched from the bootloader screen to the Motorola splash screen, and then just shut off with no further response.

So, what am I missing?

How can I flash this image onto the recovery partition of my phone?
 

seigi_tm

Junior Member
Jun 10, 2019
2
0
6
#2
hello how are you ..... you could solve the installation of the twrp ne moto g7 power
 
Thread starter Similar threads Forum Replies Date
UsandThem Mobile Devices 0

Similar threads



ASK THE COMMUNITY

TRENDING THREADS