Can't defrag or scandisk with RAID

neckcracker

Junior Member
Aug 7, 2001
6
0
0
Hi All,

Was wondering if someone could help me...

I have an Epox 8K7A+ running 2 WD 80GB as a RAID 0 setup with 64k striping and am using Win98.


When I try to defrag (or try scandisk) I get the following errors:

Your computer does not have enough free memory to defrag the drive. Quit one or more programs.
ID# Defrag009

ScanDisk could not continue because your computer does not have enough available memory.



Since I have 512MB of RAM and no other programs running, I should not be getting this error. Microsoft has the following support article for these error messages:

http://support.microsoft.com/directory/article.asp?ID=KB;EN-US;Q229154
Article Link

but it does not cover my problem.


Has anyone heard of this problem and is there some fix for it?

It would seem to me that running RAID 0 without being able to defrag it would not perform as well as just having the HDD on the normal IDE channels--as 2 separate disks BUT with the normal ability to defrag them.


Thanks in advance!
 

John

Moderator Emeritus<br>Elite Member
Oct 9, 1999
33,944
1
0
What did you use to create your partition(s) and format the array?
 

neckcracker

Junior Member
Aug 7, 2001
6
0
0
I used Win98 boot floppy to run fdisk and then did a format. These were both done after setting up RAID (ie, they were seen as 1 drive--can't do the RAID configuration after fdisk & format since you'll need to go and do fdisk & format all over again).

Neither disk was partitioned and Win98 reports them as 1 drive (C drive of course) and the correct combined size.
 

John

Moderator Emeritus<br>Elite Member
Oct 9, 1999
33,944
1
0
Try adding conservativeswapfileusage=1 under the [386Enh] in the system.ini, then try to run scandisk/defrag.