Cannot delete files.


Senior member
Feb 14, 2003
I tried to save a couple of text files through AIM and for some reason something went wrong. The files were created with the extension missing and end with a period (e.g. "textfile." ). The size of the files is 0 kb so they're not taking up any space, it's just annoying having them there because the filenames are super long. The problem is that win2k can't access the files, so it can't delete them. I was told that the reason it can't access them is because the name ends with a period (this sounds like bull to me, but maybe it isn't). I tried to see if I could rename the files to get rid of the period at the end, but again, win2k can't access the files so I can't do ANYTHING with them.

I tried deleting/renaming in both Windows Explorer and at the Command Prompt. I tried restarting the computer, still no luck. Is there any way that I can delete these files short of formatting the whole drive?

BTW, the drive is using NTFS.


Senior member
May 28, 2002
Originally posted by: OZEE
Have you tried getting to it through a DOS prompt?

Ditto. Not the DOS shell inside windoze but booting to DOS will do it for sure. :)


Diamond Member
Mar 4, 2002

drop to a command prompt and delete the file with it's shortname.

To get a list of shortnames use dir with the /x switch.

Start | run | cmd.
cd <whatever folder it's in>
dir /x
del shortna~1 (or whatever the files shortname turns out to be)

A filename that ends with a period is legal I think. Trailing spaces are not. If this doesn't work, drop me a PM and I'll help you out. The above is a simple fix. There is a sure-fire fix but it's a bit more complicated...and no it doesn't involve formatting :D