• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Question BOINC trying to connect to localhost linux

Markfw

CPU Moderator, VC&G Moderator, Elite Member
Super Moderator
May 16, 2002
21,796
10,038
136
So I fire up BOINC manager. Nothing shows in any tab, but I know its running, since its using almost 100% CPU. Now have had problems like this before, I I choose "file/shutdown connected client". In the conputer area, I click, I get a dropdown with the computer name, I select it, then the password, and BAM, everything shows up (projects/tasks, etc..) But on this box, there is no choice. I googled a little, tried "localhost" for computer and password, no change. I have rebooted restarted, etc, to no avail.

Help ! I need to change this computer for WCG
 

StefanR5R

Elite Member
Dec 10, 2016
4,289
4,885
136
Check the password:
cat /var/lib/boinc*/gui_rpc_auth.cfg

Check whether or not the client is set up to allow GUI RPC from any host:
grep allow_remote_gui_rpc /var/lib/boinc*/cc_config.xml

If it's not, check which hosts are allowed to make GUI RPC calls:
cat /var/lib/boinc*/remote_hosts.cfg

If you need to modify any of the files, you will probably need to elevate your privileges using sudo. E.g., call a command line editor like so:
sudo nano -w /var/lib/boinc*/cc_config.xml
or a GUI editor like so:
gksudo gedit /var/lib/boinc*/cc_config.xml

After you modified settings which relate to remote access, restart the client to get the changes active:
sudo service boinc-client restart

PS, documentation of the config files is here:
https://boinc.berkeley.edu/wiki/Controlling_BOINC_remotely
https://boinc.berkeley.edu/wiki/Client_configuration
 
Last edited:

Markfw

CPU Moderator, VC&G Moderator, Elite Member
Super Moderator
May 16, 2002
21,796
10,038
136
Check the password:
cat /var/lib/boinc*/gui_rpc_auth.cfg

Check whether or not the client is set up to allow GUI RPC from any host:
grep allow_remote_gui_rpc /var/lib/boinc*/cc_config.xml

If it's not, check which hosts are allowed to make GUI RPC calls:
cat /var/lib/boinc*/remote_hosts.cfg

If you need to modify any of the files, you will probably need to elevate your privileges using sudo. E.g., call a command line editor like so:
sudo nano -w /var/lib/boinc*/cc_config.xml
or a GUI editor like so:
gksudo gedit /var/lib/boinc*/cc_config.xml

After you modified settings which relate to remote access, restart the client to get the changes active:
sudo service boinc-client restart

PS, documentation of the config files is here:
https://boinc.berkeley.edu/wiki/Controlling_BOINC_remotely
https://boinc.berkeley.edu/wiki/Client_configuration
Wait. No, I am on the local computer. BONIC manager will not connect to the local host. On the local machine, I have no projects, tasks, notices, and no options, except the "file" menu dropdown choices. THAT is where I sometimes use the "shut down connected client" even though it does not appear to be connected. and it then shows everything.

And this:
sudo service boinc-client restart

Works perfectly. Let me get a screen shot to show more.

Edit: I can't figure out how to get a screen copy into the paste buffer to paste in imgur.com
 
Last edited:

Ken g6

Programming Moderator, Elite Member
Moderator
Dec 11, 1999
15,529
2,588
55
I have one computer that I can't connect to unless I go to file -> select computer, select 127.0.0.1, and leave the password field empty. I don't know why.
 

Markfw

CPU Moderator, VC&G Moderator, Elite Member
Super Moderator
May 16, 2002
21,796
10,038
136
OK, I figured it out. All of my linux boxes in the house have the same password.... except this box... Jeesh.....
 

StefanR5R

Elite Member
Dec 10, 2016
4,289
4,885
136
No, I am on the local computer.
The mechanism to control boinc on the localhost is the same as across hosts.

I have one computer that I can't connect to unless I go to file -> select computer, select 127.0.0.1, and leave the password field empty. I don't know why.
I have that too sometimes; haven't figured out a pattern behind it yet.
You can also specify host or/and GUI RPC port or/and password if you start boincmgr at the command line.
 

ASK THE COMMUNITY