• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

BOINC: Erratic CPU Usage (Rosetta@Home) (Pic)

dawks

Diamond Member
Oct 9, 1999
5,071
2
81
During the Rosetta crash, I switch some of my faster rigs over to World Community Grid to ensure they wouldn't sit idle. Two of these are Dual Core systems. One is a Pentium D 820 running Windows Vista. The other is a Woodcrest Xeon 5130 2.0Ghz running Server 2003 x86 64bit. Both were running fine until I made the switch, then the CPU usage for the exe's running on each core would spike up and down from 0%-25%... all over the place. This was happening to both Rosetta, and World Community Grid processes alike. 'System Idle Process' would be going all over too, 25%-99% and everywhere in between. After halting new work from World Community Grid on the Vista box, and rebooting it, things are back to normal. The Rosetta processes are back to maxing the processor.

I just checked my Woodcrest box, and its still having the problem. So I upgraded the BOINC client from 5.10.13 to the current 5.10.20, and restarted it. Same problem. So I rebooted the system, still the same problem. I think most, if not all of my machines are using the same settings so I don't know whats going on. Any way to fix this?

Here is a screenshot of what it looks like in taskmanager.

It is affecting my scores. The Woodcrest box is only getting about 400 points when it was about 620 before the Rosetta crash.

Thanks!
 

Rattledagger

Elite Member
Feb 5, 2001
2,987
18
81
Hmm, make sure you're not limiting "Use at most N percent of CPU time" to something less than 100%, since if it's less than 100% your cpu will crunch x seconds and be off y seconds...

Also make sure computer is using the correct Venue, by adding a new project it's possible your computer has "moved" to a different venue than you think, and it's maybe using "default" now. Also check if you're using any overrides. (Advanced/Preferences in client).


Possible other problems... your cpu-graps is really too similar all the time, so wouldn't expect any problems with being close to ram-limit so starts swapping. It's maybe possible, if hd all the time lags-behind so waits on read/write, but again really too similar.

 

dawks

Diamond Member
Oct 9, 1999
5,071
2
81
Ok I went to (Advanced/Preferences) and the first tab is CPU settings. On it, "Use at most N % CPU time" was set to 60.

Odd because I never touched that. Some kind of bug somewhere. Anyway, its back to 100%.
 

ASK THE COMMUNITY

TRENDING THREADS