• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

BF2 Problem: Splash picture doesnt go away till error

evolvedbullet

Senior member
Mar 11, 2006
543
0
0
When I install Battlefeild 2, it asks me to restart. I do and I install the latest 1.41 patch for the game. I ran the game but my startup picture (splash picture) didn't got away for about 10 minutes for some reason. I have a very good computer that can run Crysis on high settings. It crashed and gave me this error:
http://img177.imageshack.us/my.php?image=m0132grjt9.jpg
With xfire, I get:
(it takes too long, I got to hit the sake!)
I also installed the latest drivers for my video card. I could not find a video card driver that fell under the description of my video card (8800 gtx, nvida) but I saw a list of video cards that were labeled "new". This video card really isnt that new so I figured it would be ok. I downloaded this driver:
http://www.nvidia.com/object/winxp_175.16_whql.html

Thank you all for your curiosity to look and even more thanks to those who reply. :)
 

43st

Diamond Member
Nov 7, 2001
3,197
0
0
This may be related to the movies that want to play at the beginning. Do you have any 'codec packs' installed? As a general rule codec packs cause some pretty serious problems. You can try deleting all the movies in the BF2 main folder and perhaps that may work.

Some other things to try.
- Try completely removing the BF2 profile folder in 'My Documents'. It will be recreated when you launch the game.
- If you've installed a new sound card or sound drivers sometimes the game needs reinstalled, especially if the sound card get's a new ID with the driver install. I think Creative fixed this though.
 

evolvedbullet

Senior member
Mar 11, 2006
543
0
0
Nevermind, I found them but It isnt working. I deleted the EA, Intro, and Dice videos. It didnt fix it though
 
Thread starter Similar threads Forum Replies Date
H PC Games 0
Similar threads
msi afterburner problem

ASK THE COMMUNITY